Windows 11 - 22H2 - Trust Relationship

"The trust relationship between this workstation and the primary domain failed"

Hi!

I have a handful of devices out of 400~ that have the above error in Inventory. While I know this is being caused by Windows and not PDQ I was hoping that someone else had a solution!

From reading online other people have encountered this issue when running CrowdStrike or Falcon Identity Sensor. We do not.

Things I've tried:

  • Making sure time servicers across domain are in sync
  • Tidying DNS and making sure scavenging is happening
  • Restarting client and Inventory server
  • Removing client from domain, deleting from AD, re-adding client to domain
  • Performing all Windows updates
  • Running Test-ComputerSecureChannel -Repair

The domain user can log in okay but when running Test-ComputerSecureChannel I get the result of false

0

Comments

6 comments
Date Votes
  • If you've enabled automatic updates, new updates will automatically download and install whenever they're available, so you won't have to worry about rolling ball 3d

    0
  • i have the same problem...does anyone have a solution?

    0
  • Hi! We did! it turned out the computer accounts weren't in the password replication tab on the local DC

    0
  • Thanks for the reply, could you be more specific?

    0
    • Go to AD Users and computers
    • Go to your DCs
    • Right click the DC the workstation is connecting to.
    • Click properties
    • Go to password replication policy
    • make sure the computer is contained in a computer group here

    This is what fixed it for us

    0
  • Thanks a lot for the answer. Probably my domain, being non-native Windows but SAMBA (following this guide https://samba.tranquil.it/doc/en/index.html) is missing this feature... Thank you so much for your availability.

    0

Please sign in to leave a comment.

Didn't find what you were looking for?

New post