Running an install with a generated configuration file

So I'm having a problem installing an EXE that's an MSI wrapper that requires a configuration file.  One key point is on the prior step I'm generating the configuration file via a PowerShell script as per the applications guidelines as the configuration will vary from server to server.  Here's the process as I'm running it:

  1. Create foo.xml with a configuration for the server via ps script and put it in C:\Foo on the local server, this step works as expected.
  2. With the installer step use the setup line of $(Repository)\FooSoft\132\setup.exe /s /v"/L*V c:\Foo\foo_verb.txt /qr REBOOTPROMPT=REALLYSUPPRESS REBOOT=REALLYSUPPRESS UNATTEND=1 ADMINCONFIGFILE=\"C:\Foo\foo.xml"" as outlined in the applications install document
  3. The install completes, but not fully as the configuration file wasn't used/found based on the foo_verb.txt verbose log created during install

I have ensured on step 2 above that the "Includes Entire Directory" check box was checked as there are multiple additional files needed, which does copy the files over (as I don't get a missing file error). 

In an attempt to fix this I copied my package and  replaced the install step with a copy step to copy all the install files to the server, and added a command step run a batch file on the server with the setup.exe line above in it.  This also did not work

Also to ensure the command is correct I manually copied over the files to one server, ran the script to create the config file and then ran the setup line via a command prompt and everything worked correctly.

What I'd like to know is why is the setup not seeing my configuration file?  Do I need to put it somewhere else?



Date Votes
  • If it helps, I'm using PDQ Enterprise with PDQ Deploy 13 (Release 2) listed as in the Help>About window

  • Try wrapping C:\Foo\foo.xml with single quotes instead of double quotes. That way you don't have to escape them and the parser is less likely to get confused.

  • So I tried this change and now it sticks on the install step in PDQ Deploy and the log shows that it finished, but it didn't see the config file still.  I tried with and without the \ in front of 'C:\Foo\foo.xml'.  Is the user not fully logging in or something on the host?  Should I put the config file in another directory? The user PDQ Deploy is using is an admin on the server, and the files and folders are getting created as expected.  It just seems to be this step.  Would it help to give you the verbose log?

  • Quick update, I fixed it sticking at install, as it wasn't using the proper single quote.  It appears copying and pasting caused that issue, and manually putting the quote in fixed that.  However, it still isn't following the config file when run via PDQ Deploy.  The install isn't completing fully  as it's missing services and the application configuration isn't loaded based on the configuration file details.  As a note, the install still works properly if I run the same command manually on the server with the setup files locally copied when I have logged in as the same user as PDQ Deploy setup to uses.

  • Can you post a screen shot of the package step where you are defining all these arguments?


  • Here's the step in question.  I make the XML config file the step prior and that completes successfully.  Also using the parameters manually work with that same config file so I know the config file is correct.  I didn't change anything with Conditions or Options but the screenshots are below.


Please sign in to leave a comment.

Didn't find what you were looking for?

New post