Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Deploying Mathlab

Hello, I am trying to deploy mathlab with pdq and if the program ever returns an error code like -1 or -2 (file not found) pdq still returns success. Also, when the installation is still going on, pdq returns success even though the installation is still running. Is there a way to fix this or is this a bug?



Date Votes
  • Are you deploying via .exe or .msi? You'll want to make sure that you have set up the package with the correct silent parameters.

    For file not found, make sure the package is targeting the installer at the correct location.

  • Eric,

    I've been dealing with a similar issue deploying Matlab 2017a over the past week. Our issue was that the setup.exe in the root of the Matlab folder in our software repository was handing off the installation /bin/win64/setup.exe. When this happens and the original setup.exe process ends, PDQ Deploy assumes it was successful and begins deleting the installation files from the target PC. That is what causes the "file not found" error in the Matlab installer log file.

    After several days of troubleshooting (and collaborating with PDQ's support) we solved the issue by removing the installation step from our package and putting in a command step instead, which directly calls "\bin\win64\setup.exe" instead of running through the root setup.exe first. Here is what we put in our command step:

    \\server\share\\Matlab\2017a\bin\win64\setup.exe -inputFile \\server\share\Matlab\2017a\installer_input.txt

    Obviously you will have to replace \\server\share with the UNC path to the network share where your PDQ repository is located. You will also need to make sure to get the file permissions right.

    If you are defining any paths in your installer_input.txt file you should replace those with UNC paths as well. For example, we had to change our licensePath to something like this:


    Hope this helps!

  • Thank you Luke. This worked for me.