Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

File Copy not working

I am trying to do a simple file copy of a .lnk file that is on a network drive to users desktops. PDQ Deploy is saying that it is successful, but it's not working.

I am using the "File copy" step. I have verified the Source and Target paths are correct.

I have even tried to do it using an xcopy command and it tells me its successful when its actually not. I have taken the same exact xcopy command and ran it manually on one of the PC's from a command prompt and it works perfectly.

I and using the domain admin login credentials for authentication in PDQ Deploy and have tested them from within PDQ Deploy successfully.

Any ideas?



Date Votes
  • Not sure what the destination is in the package, but is it possible that it is going on to the admin desktop instead of the intended user?

    Can you post screenshots of your step?

  • Sure, here you go.

  • And the properties? Run As?

    I think you run it as "Deploy User" and not as "Logged in User"
    And if you run it local, it goes into he current user Profil, that are two different path.

    Better way use this Target Folder to deploy the link for all users:




  • Thanks Christian, that worked. I cant believe it was that simple.

  • Sideeffect, only a admin can delete a link inside c:\Users\Public\desktop (i hope your normal users don't have admin rights)

    Now you can be 100% sure that every user who use this PC has the necessary links on the Desktop.

  • I install super copier at my system but it was not working at this time I was worried about this I need to get solution of this. I searched a lot about this and finally I got this from it has all the new and old software problems with solution that was good to have.