Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Can I use custom variables in PDQ Deploy install paths?

This seems pretty elementary but I can't find anything via search.  I'm trying to set up a package for R that I can keep updated easily.  R includes its version number in its exe installer file name, so what I'm trying to do is use this for an install path


which should parse to

[My repository]\R\R-4.2.2-win.exe

PDQ Deploy correctly parses the $(Repository) variable, but not the @(AppVerR).  @(AppVerR) does exist in both Inventory and Deploy.



Date Votes
  • I have some similar packages setup.  They happen to be using DFS-N paths, but that that shouldn't make a difference.  And they don't happen use the $(Repository) because their location is slightly different.

    In your Variables>Custom settings, if you have
    the variable @(AppVerR)
    And the value is 4.2.2
    Then I expect it should work, based on mine.

    The "Command Line" field at the bottom of the install step should show the resulting filename.

  • Yeah none of the custom variables appear to be working.  I created a command step

    echo $(Repository) && echo $(DateTimeUTC) && echo @(Inventory:AppName7Zip)

    and the output is

    [My Repository path]
    3/8/2023 5:18:58 PM 

    And it does the same with all of my custom variables and all the default variables from PDQ.

  • I only use the variables in the GUI in install steps using .exe or .msi, not in separate PS or CMD functionality.

    I suggest contacting support.

  • Yeah I tried an "Install" step too but it can't find the .exe file because it's not parsing the @(AppVerR) variable.

  • I dunno if it was coincidence or not, but I had to restart the computer earlier this afternoon and when I went to test it in Inventory, it worked.  So I went back to check it again in Deploy and it was working there too.  I guess it was just a glitch?