Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

PDQ Deploy output logs not opening

Ever since Windows 11 did an update to Notepad, output logs will not open in notepad (or any other app like Notepad++ I try to direct them to).  Occasionally, the output logs will open in a small PDQ Deploy window internally but most do not open now.  It still works fine on my central server which is on 2019 and using the old Windows 10 style notepad.  Any ideas how to get this working again on my console machine?



Date Votes
  • I'm able to open up a file in Notepad ("C:\Windows\System32\notepad.exe"), but it shows there is an update available. The update directs to the Windows Store App though which is already up to date.

    This happens regardless of which notepad version I set as the default program. If I also try to open Notepad directly from system32, it opens the store app. I'm assuming that Windows has a built in redirect to use the store app and the system32 exe is more of a placeholder. But I don't know why PDQ can open the system32 notepad.

    No answer unfortunately, it's just my experience. I'd be curious if you can replicate this on other Win11 PC's or if it's just that PC where maybe something is corrupted. 

  • I just upgraded to Windows 11 and I have the same issue.  Version 22H2 22621.1992. 

    I have tried changing my txt extension to default to WordPad.  It opened up WordPad once and it said that it could not find the file to open it.  It doesn't repeat that after, until I reboot.    

    When set notepad as default it looks like it is trying to open something but nothing ever opens.   Is there another place I could open up Output Logs in the meantime, until this is fixed?  

    Thanks for looking into it.  Please let me know if I could provide further details. 

  • The output logs are stored in "C:\ProgramData\Admin Arsenal\PDQ Deploy\Deployment Output" as .gz files, which 7-Zip can open. Correlating them back to what you see in Deploy is tricky. If you're willing to use my PowerShell module, it can make it a little easier.

    Run this once. If you've never installed a PowerShell module before, you'll have to accept a couple prompts.

    Install-Module -Name 'PdqStuff'

    Run this each time you want to use my module:

    Import-Module -Name 'PdqStuff'

    Here's the script. Replace 1234 with your desired Deployment ID.

    (Get-PdqDeployment -Id 1234 -IncludeComputers -IncludeSteps).Computers | ForEach-Object {
        $Computer = $_
        $Computer.Steps | ForEach-Object {
            $Step = $_
            if ( $Step.OutputFile ) {
                    'Computer'   = $Computer.Name
                    'Step'       = [Int32]$Step.Number
                    'OutputFile' = $Step.OutputFile

    } | Sort-Object 'Computer', 'Step' | Format-Table -AutoSize
  • Has anyone gotten a resolution for this.  I, too, can't PDQ Deploy output files on a Win 11 computer.



  • I'd open a ticket with PDQ support, same issue here.

  • I opened a ticket, and they offered the PowerShell solution.  It is unfortunate, but more and more people will be on Windows 11, I hope they find a solution.  

  • Got annoyed at this too and opened a ticket. They said "You'll need to log into your computer as the Console User that you are launching the PDQ consoles as, in order to generate a complete User Profile on the console computer, then log back in with your daily account and launch the PDQ Consoles as your Console User. The Output Logs should then be able to be viewed"

    This did the trick.

  • Finally, a solution!  This worked for me, as well.  I haven't rebooted yet, but I would imagine it will stick.  Thanks for sharing James D