Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Javascript program - Win32 application error


I opened a support ticket for this but wanted to know if I can get some help in this forum.

I need assistance in deploying a javascript file program to workstations where it will uninstall old version and reinstall updated version.

I set up the deployment package using the install command and selected th *.js file.

When I deploy once to test on one machine that has old program, I get a Program id not a valid Win32 application.

I looked up the the error and ran a regsvr32 command to update my ishell.dll file but still get the error after I deploy.

I tried both 32 and 64 bit version and can't get pass the error.

Can I get some help on deploying a javascript file.  

Thank you.



Date Votes
  • Search engines and spammers scrape these forums, so I highly recommend removing your email address.

    Deploy does not recognize .js files:

    I recommend using a Command Step to call cscript.exe.

  • I removed my email address (thank you for that) and will try your suggestion and let you know.

    Thank you Colby.



  • Hi Colby;

    Deployed javascript based on screenshot.

    Got output error log.

    Microsoft (R) Windows Script Host Version 5.812
    Copyright (C) Microsoft Corporation. All rights reserved.

    Input Error: Can not find script file "C:\WINDOWS\AdminArsenal\PDQDeployRunner\service-1\exec\javascript.js".



  • Replace "javascript.js" with the name of your file. Make sure to add it to the Files field by clicking the "..." button.

  • Hello Colby;

    Thank you for the guidance.

    Aa test before running in deploy, I ran the cscript in an elevated command prompt and it did go through its process of uninstalling the old version and install the new one on my test machine.

    However, while it did execute the cscript , the java install file contains a few window prompts in its code which requires manual intervention(yes/no prompts of what you want installed) to complete the installation process.



    Is there a method or alternative that you may know to identify/extract these pieces of code in the file and set it up as a batch command?

    Accepting the yes/no prompts is the only way to successfully complete the install process to new version.


    Thank you.