How can I deploy registry keys?

Comments

6 comments

  • Adam Ruth

    My first guess would be a permissions issue getting to the server where the reg file is. If you're using you current authentication, you won't be able to access a network share from the installer. Change the authentication to specify the account name and password (even if the same as current) and then the installer service will be able to access the share.

    0
    Comment actions Permalink
  • Fillip Van Bedts

    I'm using the domain admin account and PDQD can access the bat file.(all other commands are executed)
    It's just the "regedit.exe line" that doesn't work...

    0
    Comment actions Permalink
  • Fillip Van Bedts

    Solution: Change the administrator!

    I was executing the bat-file with the Domain-admin account. registry Hive I wanted to deploy was [HKCU]...

    Changed it to [HKLM] and it works!

    My mistake...

    0
    Comment actions Permalink
  • Adam Ruth

    Excellent, I'm glad you got it working.

    0
    Comment actions Permalink
  • gil

    Did all changes:

    created batch file for import the Reg file setting

    used HKLM and not HKCU

    my batch file:

    @ECHO OFF
    regedit.exe /s fie.reg

    Also the deployment user: is Domain Administrator by default

    when deploying it

    it's not working

    when double click on file on client the file is working

    what what what to do to fix it?

    Thanks,

    0
    Comment actions Permalink
  • Shane Corellian

    What error is returned when you run this? My guess would be that the file "fie.reg" couldn't be found. Do this from an Install Step. Have the fie.reg file be the Install File. This will ensure that the file gets down to the target. (see attached)ImportRegInstallStep.png

    0
    Comment actions Permalink

Please sign in to leave a comment.