Important Notice: On February 29th, this community will be put into read-only mode. All existing posts will remain but customers will be unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

PDQ Deploy - Access denied to computer's service manager

Hi there,

I'm using PDQ Deploy to install an application on to the servers.  I have got this "Access denied to computer's service manager" error on some of the servers.  The user account i used for PDQ Deploy preference is the domain admin account.  I got the following error messages when running the Remote Admin Repair tool:

- Connect to IPC$ Share: Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed.  Disconnect all previous connections to the server or shared resource and try again.

- Create Service: Access is denied

The servers has got File sharing enabled.

Can i please get some help on what might causing the error and how can we solve it?

Thanks

Winnie

0

Comments

11 comments
Date Votes
  • It sounds like you've got a conflicting connection from your computer to those servers already, probably as a non-admin user.  Can you run net use and post the output?  We may be able to find a workaround.

    0
  • Here's the output from net use on the laptop that i was using:

    New connections will not be remembered.

    status local remote Network

    ok H: \\server1\winniex Microsoft Windows Network

    ok I: \\server1\install Microsoft Windows Network

    Disconnected \\server2\c$ Microsoft Windows Network

    Disconneted \\server3\ipc$ Microsoft Windows Network

    The command completed successfully.

     

    Both server1, server2 and server 3 has had this access denied error. there are also a few other servers that didn't show in the command which have the same access denied error as well. Tried logging into the laptop using the admin account solved the problem!! Thanks for pointint out this conflictng connection issue!! I was sure troubleshooting in the wrong direction. Does this mean that this issue is user related not machine related? And the acocunt that I used for logging in can't have any other connections to the server at the same time?

    0
  • Thanks for the information.  This is a limitation of Windows that you can't have multiple user accounts connecting to the same computer at the same time, and the mapped drives were already connected as a non-admin user.

    We will do some research on our end to see if there is a workaround we can implement.

    0
  • There's another thing I need to raise. I can't get the MSI to be installed under Local System account when I logged into the laptop using the nomral domain user account and deploy the MSI with even the authentication has been set to my domain admin account. But if I logged into the laptop using the domain admin account, then the MSI will be installed under Local System account automatically. What would be the reason for this? Is there a workaround for this when logging in as normal domain user account?

    Thanks

    0
  • When you say "installed under Local System account" what are you referring to?  Do you receive an error message?

    0
  • I mean the account that MSI using for installation. It shows in Task Manager-> Processes->User name for the MSI installation process. System account has the highest privileges over any other acocunts. So I need to have the MSI to be installed using the System account.

    0
  • Thanks, now I see what you're saying.  Unfortunately, right now it will only run under local system if you use the current user's credentials. This is a good idea for something to add.  I've put in a feature request to allow for using local system even when using specific credentials.

    0
  • Thanks a lot for your answers.
    0
  • Did this ever get resolved?  I'm getting this sporadically on identical machines, same OU, same domain, same policies.  Some work and some don't.

    0
  • Peter,

    It depends on the cause, Access Denied can come up in a number of places some we've been able to get around and others outside of our control. In the case above, our next beta will include the option to run installers as local system. 

    When you next get the error, submit it to us using the Diagnose link and we'll see what the specific problem is.

    0
  • I had a similar issue when deploying MS Office. I was a domain admin and could deploy with no problems using my account. I installed PDQ for one of our  support tech's so he can finish the installs for me. Since his permission levels were limited, I changed his default credentials to use mine but he was getting an "access denied" to the service manager. I tried changing the default credentials for the Background Service as well and then it worked.

    I do agree with Peter though, it would be great to be able to install as the the local admin at the target.

    Thanks for a great app guys...saves loads of time.

     

    Mike

    0

Please sign in to leave a comment.

Didn't find what you were looking for?

New post