Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

First attempt, hung installer

Just installed PDQ Deploy 1.5 and tried installing a new app on one pc.
(Win 7 + 2008r2 domain, using domain admin account)
It looks like it's hung, its been 30+ min and shouldn't take more than 5.
I am logged into the target pc as a regular user, there was no indication it was running, but I can see the setup program listed in task manager, so it's trying...

The vendor isn't supplying installation support beyond sneakernet installs.

Where do I start to troubleshoot this?  
Will PDQ eventually give up or do I kill it manually?



Date Votes
  • PDQ will automatically timeout after 60 minutes. It sounds like the installation may not be running in silent mode. If the installation expects user input during the install, this would cause the hanging that you are seeing. The user will not see the installation or any questions from the install, so you will literally have the installation waiting for a user response that will never come.

    You mentioned that the vendor the app you are installing only supports sneaker-net installations. If there is no way to add a silent switch then you may be stuck with a manual installation. is a good source to use to see if a particular application has a silent switch. If you would like to provide the name of the app we would also be happy to do some checking.

  • Thanks Shawn for the quick response.  I aborted after 40 min and did some poking.  Running the exe with /? said 'use /S /v /qn' for silent mode - but when I do that manually, I've now realized it's not actually running silent :-(

    It's not a common app, and not listed on

    It is an install shield installer, I guess the next step is see if I can run it with -r and create an answer file, then use -s (even though /? doesn't list those options)

    Interestingly it does mention passing options to an msi file - would it work if I figured out where it's extracting that and just used it?  Where would that msi file show up?

  • Sorry, should be working out more before I keep posting here.

    It does extract an msi file, and four other files, three that look like ini setup instructions and a prq? file.  I wish I knew more about which settings are used by default etc.

    I also tried running it with -r to create a response file, and I can't find one if it did.


    Boy I miss rpm -ivH

  • If it extracts an MSI, you could then take all those binaries (including the other files) and use PDQ Deploy to call the MSI. Just be sure to select "Include Entire Directory" so that the other support files are included. If the MSI silent installation is respected then you could have a successful installation. Please let us know if it works for you, k.

  • Nope, no dice.  Tried running the MSI including the whole directory and it just hung.  Tried it from powershell too, msiexec goes away for a while and eventually exits with no output or changes done.  I guess without further guidance from vendor support I'm going to have to install this one the old fashioned way... (RDP and coffee)

  • Do you mind revealing the name of the application? If we can obtain the installer file then we can try and install this in our lab and get back to you on our findings.