Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Can't install Citrix

I was able to deploy a flash player update without any problem, but I was not able to deploy Citrix.

Do you have any recommendations?

The .exe file was deployed from the same server that is running PDQ Deploy. Note: I'm running Windows Server 2003 R2.



Date Votes
  • Was there an error in deploying citrix or did the install just hang without doing anything? If the latter was the case it is generally due to an  incorrect parameter being passed, often the silent parameter. In PDQ Deploy will you select (highlight) the installer and go to File > Export. Please send us the file that is generated. We will load it in our lab and see what we can find.

  • Please, be also more specific. Citrix server, client, web plugin etc.

  • Installing Citrix Online Plugin Full seems to hang. A windows appear but is incomplete I see only the windows title "Microsoft Visual C++" and can't go on.

    This is what suggested to export :

    <?xml version="1.0" encoding="utf-8"?>

     <AdminArsenal.Export Code="PDQDeploy" Name="PDQ Deploy" Version="">  

     <Installer Name="Citrix Online Plugin" Description="" UsePullFileCopy="">    

    <Action Type="Package" IgnoreError="false" Title="">      

    <Package FileName="\\\myshare\CitrixOnlinePluginFull.exe" IncludeDirectory="false" MsiOperation="Install" MsiRestart="Never" MsiQuiet="true" Parameters="/silent" SuccessCodes="0,1641,3010" CustomCommandLine="">        








  • @Roberto
    If you run the installer manually on the system (using the /silent switch) what happens?

    Have you read the following documentation?

  • Running the installer manually with /silent option the installation completes succesfully!

    Looking into .exe file installation I can see multiple .msi files, thinking the installer calls on or al of these (depending on installation's switches) : this could be a problem?

  • Were there any dialogs during the setup?

  • No dialagos in the manual install, just complete the setup creating files and shortcuts.

  • there had to be some hidden dialog, but you can allways extract the msi files and deploy them individualy in the proper sequence.

  • I think (in this case) this is the best solution!

  • Hi, I have a similar issue as the poster. May I post here, or should I start my own thread? Thanks.

  • if it concerns citrix, you can continue here...

  • Hi, thanks, you had stated that, "there had to be some hidden dialog, but you can allways extract the msi files and deploy them individualy in the proper sequence."

    I'm actually trying to get the push installer to work with citrix. There is an application hang for me too and a dialogue box does pop up on the client machine, but I cannot select anything on it nor see what it says. Any other suggestions?

  • check this little free utility - unhider

    might help with the hidden window on the particular computer.

  • I had the same problem trying to install the Citrix Plug-in... the problem was that there was an interactive popup for the program causing it to hang (this would not happen when I manually installed the application). To date I have still not been able to get it to work, no matter what switches I try.

  • Gavin, do you know if there's a logging mode for the installer?  There may be an error running in a background process that's causing an error dialog to pop up or other prompt.  Another things is have you tried deploying with the "Run as Local System" option set to Yes?  There are some installers that require this and fail or hang if it's not set.

  • I too am unable to get this package to execute successfully.  There is a window that appears on the client side that is stopping this installation from completing.  I am running the install with the /silent /noreboot options.  I have tried removing those as well with no luck.  Any help would be greatly appreciated!



  • What version of Citrix are you installing? The parameters may have changed since the last posts.

  • Citrix online web plugin v. 12.3

  • Will this parameter work with your installation:

    /silent ADDLOCAL="ICA_Client,PN_Agent,SSON" ENABLE_SSON="yes" ENABLE_KERBEROS=Yes SERVER_LOCATION="http://citrix"

    Found on:

  • i am having the same issue removing the Citrix clients , i keep getting an error popups, 

    Disable the Interactive services, 

    this stops the PQDeploy push.   HELP please i have been trying to figure this out for a while

    i am uninstalling the Citrix pnagent 12.1.44   and trying to install the Citrix receiver 3.4

  • Hi Gino,

    If you are seeing the Interactive Services display on the target computers this means that the OS is preventing a message from being displayed. This is usually the case if there is a corrupt installation of the program you are trying to uninstall or install. This could also happen if silent parameters weren't used. What are you using to uninstall previous versions? What command are you running in PDQ Deploy?

  • Hi still haviong this issue, Do you know why the Microsoft Visual C++ runtime library error pops up and stops all deployments?

    Does PDQ Deploy use this program to uninstall?

  • I spent many hours on this problem until I ran across post. The moment I set my package to "Run as local system" like Adam Ruth suggested on comment: July 18, 2012 00:37, the install went through without a single problem. Woohoo !!!  The "Microsoft Visual C++ Runtime Library" dialogue problem went away and the install continued as it should. I tried with the individually extracted MSI files as well as with the single executable: "CitrixOnlinePluginFull.exe /silent" and it worked both ways.


    Thank you Adam!