Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

AutoCAD 2011 Image deployment with PDQ Deploy

I'm having some trouble deploying my silent installation of AutoCAD 2011. In the deployment creation, there is a "silent" checkbox which allows it to deploy without user interaction, but the deployment always seems to hang. I've tried a few different parameters and none seem to work. Has anyone else successfully deployed AutoCAD with PDQ? Should the full UNC path be used to specify the .ini file or will checking "Include Entire Directory" take care of that?

Here are the two parameters that seem like they should work:

Setup.exe /Q /I AutoCAD2011-32Bit.ini /Lang en-US


Setup.exe" /qb /I AutoCAD2011-32Bit.ini /language en-us



Date Votes
  • One way to check if the parameters are correct is to manually install on a target system by copying the media locally to the target, and then running the installation in a command window using the same parameters that you specify in PDQ. This will sometimes show dialog that can give a clue as to why it's hanging. 

    As far as the INI is concerned, you will usually still need to specify it, but if the INI lives in the same directory as the the setup.exe, you should be able to just specify it without the path. When you check Include Entire Directory the media is copied to each target systems ADMIN$ share before being executed. 

  • Would a UAC prompt hold up the install? Seems to be the only thing that pops up. The rest is silent.


      Anyways, I was able to deploy AutoCAD instead using the MSI deployment that also gets created with the Admin Image. Had to specify two different Transform files but PDQ handles that quite nicely! In addition to the Main MSI you must also install the AcadLP.msi located in the <proccessor-Arch>\<locale> folder using the gpo.mst and <your-deployment-name>.mst. I have both 32/64 going out in the same package. Hopefully this helps someone else trying to deploy AutoCAD.

  • UAC would not cause a problem in PDQ. The challenge (as you have learned) is that AutoCAD has a ton of moving parts. In addition to the application itself you C++ libraries and other apps that need to be installed and tweaked and hundred other things. Automating AutoCAD installations has probably driven more than one sys admin to raging, double-fisted alcoholics.

  • I would kiss the both of you if I could. I've been rooting around in that INI and have finally gotten it to work properly. Now to do Civil3D.

    One thing I was curious about though, is whether the GPO.mst is really necessary if you are just doing it from PDQ? I've tested it without on a couple computers and so far I haven't found any issues with it. In the Autodesk Exchange it mentions both, but it also only talks about either doing it from GPO or manually clicking the .lnk.

  • I figured the GPO.mst applied some settings such as license server or installation settings. I haven't tried it without though. My first deployment using the MSI installers + .MST files is going out tonight to 8 clients. First time failed because I forgot to re-enable steps after testing! I'll let you know how it goes.

  • Hmm.

    Ok so I somehow introduced an error, or missed something. After testing those deployments, I realized should actually open a file and try and use it. Well it is doing the "File Not Found: acad", and no menu bars, and FONTALT not set.  I've ran into this before for various reasons, but when I go back to a previous snapshot on the VM I'm testing this on, and instead use the INI method, it doesn't miss anything and obviously has no problems with this. I tried this with GPO.mst used as well since there is no reason not to use it really, and I was hoping it was caused by this, but no dice.


    Did either of you run into something like this? I'm sure it is just a step I missed, and the fixes I've seen and have used before are all to set the registry entry for acad.cui and the everything, but it should've done that anyway through the MSI and MST's I thought 

  • Hello,

    I am very interested in the installation of Autodesk products and especially Civil 3D. Have you managed to install this software? if so, can you give me the procedure please? So I'll try soon and give you my opinion on the installation

    Thank you in advance

  • I eventually ended up just using Autodesk's deployment builder utility and then wrote a batch file to copy the installation media and run the silent installation. I think the MSI + MST solution still works but I just got sidetracked and did it that way instead since it was faster. Ultimately when we switch to AutoCAD and Civil3D 2014, I'll probably take a look at doing it over again. Sorry. I can go through my notes to remind myself what I tried if you need but I don't think I did much after the last time I posted here.