Deploy Autodesk Products with Integrated Silent Installer

Comments

73 comments

  • mrnuctracker

    Also, I put these commands in a bat file, and pointed PDQ Deploy to the bat file, instead of pointing to the setup.exe file with arguments.

    0
    Comment actions Permalink
  • Pete Chenard

    Although I have successfully installed AutoCAD Civil 3D 2014 via PDQ Deploy, I have not been able to say the same for AutoCAD Civil 3D 2015.  However, I believe it is because I customized some of the paths that require a specific drive mapping.  I need to do more testing to be sure that is the problem, but it is something to consider as a potential issue.

    0
    Comment actions Permalink
  • Dan Carp

    Thanks guys... tried creating a BAT file with this content and running it:

    "\\localserver\Autodesk\BDS Premium 2015\Img\Setup.exe" /w /q /I "\\localserver\Autodesk\BDS Premium 2015\Img\BDS 2015.ini" /language en-us

    When I run the BAT file from a command prompt, it seems to run for a few seconds then return me to a command prompt (nothing accomplished, nothing logged).

    Going back to my second post in this thread, the issue seems to be the same.  It's strange because if I copy the contents of the link file (below) and run the command in a command prompt, nothing happens.  But if I double click the .LNK file, everything installs perfectly.

    "\\localserver\Autodesk\BDS Premium 2015\Img\Setup.exe" /qb /I \\localserver\Autodesk\BDS Premium 2015\Img\BDS 2015.ini /language en-us

    @Pcchenard - I used to use mapped drives and found it caused headaches later on. I now specify UNC paths and installers seem to be happier.  If I remember correctly, it caused problems when trying to install without domain admin rights.

    0
    Comment actions Permalink
  • Dan Carp

    Finally figured out my problem, accompanied by a smack to the forehead.  My "/l" (lowercase L) switch was typed in as "/I" (uppercase I).  Only saw it when looking carefully at the command within Command Prompt and seeing it in a serif font instead of sans.  Which of course would explain why the install was never logging.  To confirm, the solution presented previously is working beautifully (with a lowercase L!!!):

    "\\localserver\Autodesk\BDS Premium 2015\Img\Setup.exe" /w /q /l "\\localserver\Autodesk\BDS Premium 2015\Img\BDS 2015.ini" /language en-us

    0
    Comment actions Permalink
  • Shane Corellian

    I want to update one piece of data. You can now run deployments in "interactive" mode if needed. In Pro mode of PDQ Deploy you can specify a "Run As" option per step. Go to the step that needs to run interactively and choose either Run As Logged On User or Run As Deploy User (Interactive) under the Options tab. If the step must be executed by the end user then choose the former. Keep in mind that if the installation requires admin rights then this user must be an administrator. If the installation requires admin rights and just needs to be executed interactively then choose Deploy User (Interactive). http://www2.adminarsenal.com?docs-pdqdeploy&credentials_preferences.htm

    0
    Comment actions Permalink
  • rajkumar kushwaha

    hi

    As i am working on autocad 2015 . there is no download option as present in other autodesk product like autocad lt 2015.

    So suring installation there is no option "create deployment".

    can you suggets how to create deployment for AUTOCAD 2015.

    0
    Comment actions Permalink
  • Pete Chenard

    I'm not sure what to tell you.  When I run the Setup.exe on my product "Infrastructure Design Suite Premium" there is an option to create a network deployment.  I also have this option when running the setup for the Vehicle Tracking software so I would expect all Autodesk products to have this option just as they always have.

    0
    Comment actions Permalink
  • rajkumar kushwaha

    thanks budy for reply.

    but these all are my finding can you look into that

    I am currently working on AUTOCAD 2015 in which English version is not available for download only install option is present as shown below from given site

    AutoCAD 2015:  http://www.autodesk.com/products/autocad/overview

     installonly.png

     

     

     

    We tried in different browser but we are getting the above results.

    If we change the language than we are getting download option

     

     other language.png

     

    So while downloading other language shortcut are coming in other language only

     

    shortcutgerman.png 

     

    If we apply English patch from site

     

    http://knowledge.autodesk.com/support/autocad/downloads/caas/downloads/content/autocad-2015-language-packs.html

     

    We are getting both the shortcut i.e. in English and German as shown below

     shortcutboth.png

     

     

     

    So can you pleas esuggest for single installation as we need to do double installation 1 fro german language and other for english patch and we are getting shortcut for both.

    0
    Comment actions Permalink
  • Pete Chenard

    You cannot create a network deployment using the trial software.

    0
    Comment actions Permalink
  • rajkumar kushwaha

    just i need the complete source fro eng version of autocad, we are getting for other languages but not for english version

     

    0
    Comment actions Permalink
  • rajkumar kushwaha

    can you please visit the attcha file for more clearification

    that we are not geting option for "create deployment" option in  english version

     

     

    0
    Comment actions Permalink
  • Pete Chenard

    I'm sorry.  I can't help you.  You will probably have to contact Autodesk.

    0
    Comment actions Permalink
  • Derrick Young

    So I have been struggling for a few days now trying to get Autocad 2015 LT deployed.  It feels like I have tried every permeation listed in this thread with no success.

    Currently I have built a 2015 LT deployment that is on a share on our network.  I have a .bat file that is in the root of the deployment files. that contains the line

    \\itserver\deployment$\autocad2015lt\Img\Setup.exe" /w /q /l "\\itserver\deployment$\autocad2015lt\Img\BDS 2015.ini" /language en-us

    MY package contains the Line

    \\itserver\deployment$\Applications\autocad2015LT\deploy.bat

    with the command line of

    cmd.exe /s /c ""deploy.bat" "

    I have tried editing the command line to remove 1 set of quotes and both sets with no change

    This is returning Error Code 1

     

    0
    Comment actions Permalink
  • Derrick Young

    A little more information as I continue to test.

    I added the parameter to my deployment

    > c:\deploy.txt 2>&1

    when viewing the text file it contains the following

     

    C:\windows\AdminArsenal\PDQDeployRunner\service-1\exec>\\itserver\deployment$\applications\autocad2015lt\Img\Setup.exe" /w /q /l "\\itserver\deployment$\applications\autocad2015lt\Img\imgx64.ini" /language en-us
    The system cannot find the path specified.

    I have copied the unc path direct from the above statement and pasted into explorer on target workstation and it see path no problem.  However when I look in the target computer under c:\windows\AdminArsenal\PDQDeployRunner the directory is empty.  Now I am not sure if it is that way unless a package is being deployed or not.

    Also is the lack of space between the \exec>\\itserver.......

    Is that possible cause?

    0
    Comment actions Permalink
  • olan angulo

    derrik young i believe that all this is executing from command line  which would not allow you to use a UNC path to a network share- im not sure if its supported in a batch file but you would have to use PUSHD " your network path here" to mount a temporary network drive to the location of the network files - you will want to do a POPD after your done to disconnect the drive

     

    0
    Comment actions Permalink
  • Shane Corellian

    Hi all,

    I asked a customer who has had success deploying to AutoDesk products to share some of his packages. In order to get AutoCAD to deploy successfully he has had to really dig down into both products (AutoCAD and PDQ Deploy) to get these to work.

    He has found that many of the MSI files used by AutoDesk require the /passive parameter. To accomplish this he uses a Command Step instead of an Install step. He also keeps all the install files on a file server and all of his MSI and EXE calls point to the respective files on this file server. Note, you MAY need to change the Options for these steps (that use the /passive parameter) to run as Deploy User (Interactive).

    I have attached his "Autodesk AutoCAD Mechanical 2014" package. This may be a good starting point for you. You will, obviously, need to correct the UNC paths to point to the proper installation files in your organization.

    I'm not sure if this has been mentioned but I found this file on AutoDesk's site. It may also help you as you build your AutoDesk packages.

    0
    Comment actions Permalink
  • David B.

    I was also having trouble getting AutoCAD to work with PDQ Deploy.  I finally got it to work by changing my deployment in AutoCAD.  I had mapped network drives in my support content section, once I changed them to "program install folder" on the c: drive, my PDQ Deploy worked just fine.

    0
    Comment actions Permalink
  • Josh Stephens

    This string added as a command line step worked for the standard AutoDesk Inventor deployment that the setup file created (edited to remove organization-specific info):

    "\\server\Robotics Lab\AutoDesk Inventor\Img\Setup.exe" /w /q /l "\\server\Robotics Lab\AutoDesk Inventor\Img\AutoDesk Inventor.ini" /language en-us

    0
    Comment actions Permalink
  • Billy Ray

    Can someone upload their xml or send some screenshots of a Building Design Suite Premium 2016 install that is working for them?  Wore out our 30 day trial just trying to get this to work.  TIA

    0
    Comment actions Permalink
  • Erik Dantes

    We have Building Design Suite and created some deployments for it.  Doubling clicking the lnk created by the ADesk deployment  worked, but duplicating it's contents in a PDQ package failed with a 259 error.

    Tried many of the things listed in this thread.  What eventually worked for us was too simple, duplicating the stuff in the LNK and put it in a BATch file.  Making sure to add the /w switch.  Then point PDQ to the BATch.  The /w switch makes the installer wait for the subprocesses to complete before returning it's success/failure code.

    A gotcha.  Make sure to check that the timeout is long enough for your environment.  The packages take forever to install.

    The thing that helped the most was to Run As Deploy User (Interactive).  That helped us identify the issue(s) and eventually find the simplest solution.

    0
    Comment actions Permalink
  • TroyGates

    I have been successfully using a BAT file for Autodesk products (2014/2015/2016) with the following info:

     

    \\SERVER\SHARE\Revit_2016\Img\Setup.exe /I /W /noreboot /qb \\SERVER\SHARE\Revit_2016\Img\Revit_2016.ini /language en-us

    0
    Comment actions Permalink
  • Dan Carp

    Since we're around to the latest release of Building Design Suite 2017, I thought I'd post my process to successfully deploy.  I did not require the BAT step but followed the advice of others to simply insert the following line into a Command step:

    "\\server\Autodesk\BDS\2017\Img\setup.exe" /W /q /l "\\server\Autodesk\BDS\2017\Img\BDS 2017.ini" /language en-us

    The important note is that following the /W and /q flags is a LOWERCASE L (not an uppercase I (as in eye)).  I've attached my XML export for convenience.

    Good luck!

    2
    Comment actions Permalink
  • Jason Hanks

    Hi Dan,

    Thanks so much for putting this out for other customers running into the same issues.  Very much appreciated.

    0
    Comment actions Permalink
  • Jon Hartman

    Dan,

    Thanks for the info, I've been scratching my head for a few days on this.  Plugged the paths into the command like you mentioned and it worked like a charm.

    Thanks again!

    0
    Comment actions Permalink
  • Jon Hartman

    Actually spoke too soon.  Install seems complete but I get a status failed due to exceeded timeout.  The install run time is over an hour.  I know a Civ3D install can take quite a bit but shouldn't the /q handle the timeout issue?

    0
    Comment actions Permalink
  • Dan Carp

    Hi Jon - I don't believe that the "/q" flag addresses PDQ's timeout.  It would only specify to the Windows installation package to run in silent mode.  I neglected to mention in my original comment, but it would be a good idea to increase the timeout within your PDQ Deploy package to at least 90 minutes if not more (depending on exactly what products you're installing and your network / computer speeds).

    0
    Comment actions Permalink
  • TroyGates

    Jon,

    The default timeout for a package is 60 minutes. If it takes longer than that you can set a custom time in your package to extend it. But, if you don't have any other steps after the Civil 3D deployment, it will still complete the install, PDQ won't cancel the command line.

    0
    Comment actions Permalink
  • Jon Hartman

    Bumped it up to 90 solved my problem.  Thanks for the help!

    0
    Comment actions Permalink
  • Christopher Walker

    I am still working on installing AutoDesk2017 from the network deployment a now retired employee had created. I am currently testing the PDQ command step with the following:

    "\\server\Downloads\PCInstallFiles\Labs\Interior Design\FreeSoftware\2017\Img\Setup.exe" /W /q /I BDSU2017.ini /language en-us

    I see many people are using the path to the ini file as well. Has anyone else had success not having the path to the ini file when launching from a command step in PDQ?

    Also just for my own understanding, The .txt file in the SMS_SCCM scripts folder states that this command should install everything in our deployment package.  ".\Img\Setup.exe /W /q /I Img\BDSU2017.ini /language en-us" the command before the .ini is a uppercase i not a lowercase L so I was wondering what changing the uppercase i to the lowercase L does? and why not the uppercase i ?

     

     

    0
    Comment actions Permalink
  • Dan Carp

    Hi Christopher - I'm not entirely sure why you might be looking to install without the INI file specified.  As I understand it, the INI file is what contains all of the settings that you specify when generating the Autodesk deployment.  Could you explain why you might not want to use it?

    As for the /I flag, it indicates a deployment installation.  This might not be your exact product and clearly this forum isn't for SCCM deployments, but step 10 explains the flags used here:

    https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/CloudHelp/cloudhelp/2015/ENU/Autodesk-NetworkAdmin/files/GUID-E92C18C6-D7C9-4D6B-BFC8-B59B04F19C7C-htm.html

    Best,
    Dan

    0
    Comment actions Permalink

Please sign in to leave a comment.