Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Deploy Autodesk Products with Integrated Silent Installer

On a yearly basis, we install the Autodesk suite of products to our workstations.  The suite includes a deployment tool that can be used to create a silent deployment for individual workstations.  The deployment, in this case of the 2014 Building Design Premium suite, for an individual workstation is kicked off by a shortcut with the following target:

"\\Path\Img\Setup.exe" /qb /I \\Path\Img\DeployParameters.ini /language en-us

I would have thought that I could kick this process off via PDQ Deploy by pointing Install File to the setup.exe and including the balance of the link in the Parameters field.  When I try to initiate a deployment, however, PDQ Deploy connects but then runs until the process times out.

Further, when starting the deployment manually by double clicking the link, a dialog box appears with installation progress (no need for user input, however).  When starting with PDQ Deploy, nothing shows up which makes me believe nothing is being executed.

Could you suggest what I might be missing and how I could kick this off successfully?  Thanks in advance!



Date Votes
  • Hi Dan, Thanks for the reply. Sorry for any confusion, my first attempts at using the command remotely with PDQ seemed to launch and install correctly without having to add the full path to the .ini after the switches, using just this as the command line:

    "\\server\Downloads\PCInstallFiles\Labs\Interior Design\FreeSoftware\2017\Img\Setup.exe" /W /q /I BDSU2017.ini /language en-us

    Both the setup and .ini are in the same location and the install launched without error. However after some more testing I used the full path for everything and things seemed to be working well.

    Thank you very much for the link that was very helpful. I am still confused by your statement from: 5/2/16 "The important note is that following the /W and /q flags is a LOWERCASE L (not an uppercase I (as in eye))." Whereas in the link you provided it shows using an uppercase i and not a lowercase L?

    All in all from this thread and the Videos from Admin Arsenal all is going well.

    Thanks, Chris

  • Hi Chris - gotcha re: the INI path.  Makes sense!

    I didn't even pick back up on the I vs L discrepancy again.  I know that earlier in the thread I ran into issues when I deployed with the "/I" (eye) flag but when I switched over to the "/l" (ell) flag, it ran properly.  When I looked at the link that I provided, it does indeed specify the former.  However, here's another one where they confuse both versions...

    Apparently I don't have a good answer for why one versus the other or which would technically be correct.  About all I can say is that I've had luck using the latter but not the former!

    (And as much as I prefer sans fonts, this certainly is a good argument for the use of serif fonts in technical forums!)

  • Hey all, thanks for the information.  I do have another question to add to this informative thread:  I've used the install command line settings as above, however my install never completes.  I mean, everything gets installed as it should on my test machines completely, but PDQ Deploy keeps on deploying - it doesn't stop (at least for the 2 hours 38 mins I had time to let it keep going.)  Running the install from the regular shortcut does fine, so I'm wondering if I've missed a step.  Other installs work fine and complete successfully, but this is my only one thru command line.  This may be more of a general PDQ Deploy question than Autodesk one...

  • All,

    I'm happy to report that my deployments are working well, and the command was actually even simpler than I thought once working.  My command line in the deployment is actually, simply:

    call "\\server\Deploy\Autodesk\2017\Deployments\BDSP2017_OE\Revit2017.lnk" /W /q

    And that's it.  The deployment is kicked off from the shortcut.  This is a little different than deploying everything first go-round, and then building from the individual setup.exe file and the corresponding .ini files.

    Lots of customization options.

  • Colin, would you be kind enough to tell me exactly where you placed your example in PDQ deploy?   I have about 60 workstations to deploy 2017 and have tried about every combination possible and still cant make it work.



    Kenny Houston

  • @Kenneth,

    I'm not totally clear on what you're asking.  I have the deployment set up in the standard structure that is generated when you build the deployment, making sure the path doesn't get too long.  I'll try to attach an image of my basic 2017 install step.  I just created a full install, not customized, but including all resources as a base install, BDSP2017.  Then I spun off a Revit one.  It can be customized using the Autodesk deployment tool like you would without additional scripting.  Just so it generates the shortcut.  Then use PDQ's command line to point to it and call it.

    In addition, I did add 1641 as a success code.

    That's basically it.  I then incorporate that as a nested step in a full process, removing 2014 products, installing service packs and updates, pushing content/settings, a powershell or two to set some UI stuff, and a few other things.

  • Just using the normal default structure...

  • That's what I thought I had done.   Let me review and try again.   I do appreciate your quick response.   I know there were several places to put in commands to PDQ.  That's really what I was asking, but your screen shots cleared that up nicely.    Post results soon.

  • Good luck.  The bigger breakthrough came for me when I set the Options to continue if the deployment failed.  So it would fail with error code 1641, but the installs would complete.  I think 1641 has something to do with the machine wanting to restart (but doesn't need to.)  I then added 1641 to the success codes.  That made it tick.

    I noticed a number of the PDQ deployment collections also have 1641 as success, so it made some sense to me.

  • Thanks, 1 hour 18 minutes later the first deploy installed!   I'm not sure if it was the 1641 or the "space" after the /w that got left off, but it worked GREAT!    Now to go tweak the AutoCAD deploy side to make it a little smaller.    Colin, I do sincerely appreciate your comments and help.   I hope I can repay the favor one day!


  • This time it just runs without an end or completion.

  • Just thought I'd post a related note.

    After reading this whole thread (and many similar ones), I finally made a working Navisworks Freedom 2016 package.

    One command step, running it from our DFS share:

    \\\PDQ\CustomPackages\NavisFreedom\Img\setup.exe /w /qb /l \\\PDQ\CustomPackages\NavisFreedom\Img\Freedom2016.ini /language en-us


    That should be a single line, one space between the /l (a lowercase L) and the second \\

    Takes about 2 minutes to complete on an ethernet connection.


    Still haven't been able to make a working 2017 version.

  • Hey Grant!

    If you try this:

    \\\PDQ\CustomPackages\NavisFreedom\Img\setup.exe /W /q /I \\\PDQ\CustomPackages\NavisFreedom\Img\Freedom2016.ini /language en-us


    Does it work then?