Avaya One-X Agent

Comments

20 comments

  • SelfMan

    So far I have seen in the instructions:

    You can install Avaya one-X Agent through an automated package distribution tool that makes use of the Microsoft Windows Installer service. The Avaya one-X Agent installer packages contain the MSI Installer. To pass custom (user-defined) properties to the MSI installer, you must extract the MSI installer image from the Avaya base package installers.

    Check this PDF http://downloads.avaya.com/css/P8/documents/100069931

    Section: Installing Avaya one-X Agent silently

    The instructions are pretty stright forward.

    0
    Comment actions Permalink
  • Shawn Anderson

    Where did you get the /silent switch from? Was it in the documentation? 

    0
    Comment actions Permalink
  • SelfMan

    The documentation is a bit older, but I don't think it has changed much.

    0
    Comment actions Permalink
  • SelfMan

    Ah here is a newer one http://downloads.avaya.com/css/P8/documents/100141166 (2011)

    0
    Comment actions Permalink
  • Brock Ashley

    yeah the /silent switch was from running onexagent.exe /? from command prompt. The documentation says to run /qn which i also tried which also gave me a success result. (I forgot to mention it) but in the installation package there is not an msi file only an exe.  And the newer documentation does not mention the msi.

    0
    Comment actions Permalink
  • Shawn Anderson

    When you install with the /qn does PDQ report a success but then upon inspection nothing has been installed?

    0
    Comment actions Permalink
  • Brock Ashley

    Yeah same thing.

    0
    Comment actions Permalink
  • TonsOFun

    Brock, Try running just the installation Without silent mode to see if there are any error messages. 

    For the sake of this post, i tried to run it and got the exact same results as you. it says "success", but nothing happens on the machine. 

    However, when i run it in verbose mode, i get an error, something about Architecture being x86. perhaps there is a 64 bit version? 

    I've never had this issue before from a straight install. so something's up. maybe a windows update caused this to not work anymore?

    0
    Comment actions Permalink
  • SelfMan

    There might be one other problem too. Some of the required components are not installed. Like for example the dotNET Framework.

    0
    Comment actions Permalink
  • Brock Ashley
    I don't know if it matters but I am running pdq from a 64 bit Windows 7 machine and trying to install to 32 widows xp. Ill have to try it again without the silent switches. Which won't be until tomorrow or Monday.
    0
    Comment actions Permalink
  • SelfMan

    this happend when I run the setup file (OnexAgentSetup2.5.01072.0.zip) normally

    "C:\Windows\System32\msiexec.exe"  /lv*x "C:\Users\myprofile\AppData\Local\Temp\onexa.log"  /i "D:\application\etc\OneXAgentWIXSetup.msdb"

    so may be you could try a batch where you call msiexec.exe like

    msiexec.exe /i ".\etc\OneXAgentWIXSetup.msdb" /qn

    0
    Comment actions Permalink
  • SelfMan

    BTW if you have the same installer... have you selected the additional files folder and checked the "Include entire directory" checkbox?

    0
    Comment actions Permalink
  • Brock Ashley
    Yeah I had it include the entire directory. It failed on pdq if I didn't.
    0
    Comment actions Permalink
  • SelfMan

    have you preserved the entire file and folder structure hierarchy as it is in the zip?

    0
    Comment actions Permalink
  • Brock Ashley

    Yep i left the file structure the same

    0
    Comment actions Permalink
  • TonsOFun

    Hi Brock, were you ever able to figure this one out? 

    0
    Comment actions Permalink
  • SelfMan

    You did not mention if you tried the:

    msiexec.exe /i ".\etc\OneXAgentWIXSetup.msdb" /qn

    0
    Comment actions Permalink
  • Brock Ashley
    Sorry I haven't been able to test it out yet. I ended up getting bronchitis. Im hoping to be back to work tomorrow and ill let you guys know how it goes.
    0
    Comment actions Permalink
  • Brock Ashley

    Years later lol...
    msiexec.exe /i ".\etc\OneXAgentWIXSetup.msdb" /qn

     

    That worked perfectly when i was sick my co-workers installed it all by hand, now I have to roll another site over so this will come in handy, thanks again. 

    0
    Comment actions Permalink
  • Jennifer Perez

    hi. i was using avay one x agent for a month but not it has an error , it is "error to start" for many times I remove the app and tridad to installed again but is the same error, please help me.

     

    0
    Comment actions Permalink

Please sign in to leave a comment.