Recent builds appear that deployments no longer show any attempts

I'm opening this new ticket as the previous one I'm unable to locate.

It appears that in recent builds, and two times today with two separate customers I've had deployments stop working. Rather, these installations have been working before and now any new deployment will have all machines stuck at the "Queued" status.  I have upgraded both installations to the latest release 4 in hopes that would help, but no luck.

I've tried the typical "stop/start" of the service and has worked for a single machine, but right after the next deployment of 600-900 machines just stays with all machines "Queued". We are now unable to in both environments to get even a "Connecting" in the status window.

I have created two videos showing the issue and attempts to resolve, if you have any additional steps, i'd be glad to provide more information. 

 

http://ftp.sam-experts.com/Ken/PDQ.mp4

http://ftp.sam-experts.com/Ken/PDQ2.mp4

0

Comments

10 comments
Date Votes
  • Hi Ken,

    Sorry that you are seeing this problem. Sometimes a computer will be "stuck" in a particular stage (usually Queued or Aborting...)

    Try this. Go to Preferences > Database. Open the SQLite console. Run the following command. This will delete any computer that is in the Queued stage.

    delete from DeploymentComputers where stage = 'Queued';

    *note that Queued is case sensitive*

    Close the SQLite command window. I would also recommend restarting PDQ Deploy.

    Please keep an eye on this and let us know if the problem keeps popping up.

    0
  • Ken,

    Do you have any errors in your event log from PDQ Deploy?

    0
  • We've tried running the SQL command on both instances, on one, it didn't appear to resolve the issue after restarting PDQ.

    On the second, it appeared that after waiting for about 15-20 minutes of seeing "Queued" - it did eventually begin to start deploying.

    @ Adam

    If you look in the second video, around 3:00 minutes, you'll see all of the entries in the even viewer running with all logs, including debug.

     

    0
  • Ken,

    Sorry for the delay in getting back to you, we've been trying to duplicate this issue here.  We have seen something similar happen a couple of times, but not quite the same.  

    When the deployments are stuck in Queued do you see the background service process taking a lot of processor? 

    0
  • Appears that this customer had many machines that were very remote with a very low connection speed and that there was a schedule that was re-occurring regularly, but the previous deployments were still running or “hung” which maxed the default 8 machines x 32 max x 4 deployments and hence the “current” deployment was always on “queued”.

    I think we can only do so much with these types of connections, but some machines were “stuck” for hours and days even with a timeout or 60.

    -Ken

    0
  • Ken,

    The timeout only applies once the deployment starts on that computer, so the clock doesn't start ticking while queued.  We've had a couple of requests to change this so that there's an overall timeout that includes the queued phase but we haven't decided the best way to approach it yet.

    0
  • Thanks Adam for the update, yea, I think it’s a tricky one to handle as well. Perhaps breaking it down by phases might give the most flexibility, ex. “Running = 60 min, Connecting = 10 min, Queued = ?” but Queued would be touch because you could have 5 machines and all would go right away with a default of 8 machines, but if you had 1,000 machines or a long installation, that timeout would be much higher.

    I think we can resolve this ticket as an issue and perhaps leave it to “Feature requests” to continue the conversation any further on specific type of timeout handling.

    Thanks again for the follow up!

    0
  • Hi Adam/Shane,

    I had another customer today and tried to reply to the ticket :

    #18545 RE: Recent builds appear that deployments no longer show any attempts

     

    But not sure if it posted or not,  I attempted to stop everything and run the SQL command above, but still only a max of 6 or so machines will work anything larger will just stay in the Queued state.

    Anything else I can look into?

    0
  •  

    Hello guys,
    I'm going throughthe same issue, any deployment will have all computers stuck at 'Queued' status.
    It works for single deploys, but when I try for 30 computers, or 100 it gets stuck.

    Do you know the RCA or a possible solution ?

    0
  • Hi Jorge,

    What OS is the console running on? What values are set for your concurrent connections in Preferences > Performance?

    0

Please sign in to leave a comment.

Didn't find what you were looking for?

New post