Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Problems with Antidote


I'm having problems deploying the software Antidote. This is a French professional spell checker which comes with dictionaries as well as plug-ins for most browsers and office products.

We have in our organization an MDT server where we created a package for this application. It deploys perfectly when we use an MDT task sequence but it doesn't work properly when I use the same commands in PDQ Deploy. On MDT we call a batch file which calls various exe and msi files. It looks like this :

@echo off "%~dp0msi\vcredist_x64\vcredist_x64.exe" /q "%~dp0msi\vcredist_x86\vcredist_x86.exe" /q msiexec /qn /i "%~dp0msi\druide\Antidote8.msi" /update "%~dp0msi\druide\Maj_Antidote8_v3.msp;%~dp0msi\druide\Maj_3_Modules_Antidote_8_v3.msp" TRANSFORMS="%~dp0msi\druide\Reseau.mst" msiexec /qn /i "%~dp0msi\assistantTelechargement\AssistantTelechargement.msi"

So the files here are the Visual C++ redistributable files, the main msi file for the program, 2 patch files as msp's, a transform file which contains the serial number and the plug-ins integrations, and finally a download manager that is used to update the program.

As i said, when we deploy this script with an MDT task sequence it works fine. Now in PDQ deploy I tried calling the same batch file (and including the whole directory) but it didn't work very well. So I tried lots of things. I tried to deploy only the main msi file with the 2 patch files and the MST as a parameter. The line in PDQ Deploy looked like this :

msiexec /qn /i "Antidote8.msi" /update "Maj_Antidote8_v3.msp;Maj_3_Modules_Antidote_8_v3.msp" TRANSFORMS="Reseau.mst"

All files are within the same folder (and the whole folder is included). The install failed with a 1635 code which seems to be an unknown msi error. I think it didn't like the /update parameter but I don't know why...

So I tried without the patches (as I can install them afterwards anyway) :

msiexec /qn /i "Antidote8.msi" TRANSFORMS="Reseau.mst"

It kinda worked...the files were copied in the Program files directory, the parameters in the transform were applied and the app appeared in in the programs and features panel. But the installation was not totally complete. There were no shortcuts in the start menu for example. So I have to manually start the exe in its program files directory to complete the setup. (although I have no further interaction to do with it)

I also tried creating multiple steps in my PDQ deploy package to copy the behavior of my batch file. The result is always the same...the files are copied in the program files folder but no shortcuts in the start menu. I always have to manually launch the program so that it can finish its setup. I also tried adding a "Command line" step at the very end of my PDQ package to execute the program but it didn't fix the problem.

And again I don't have these problems when I'm deploying this same package using my batch file on my MDT server...So I don't know if this is some kind of bug with this precise application and PDQ but it's quite weird.

Any help would be appreciated.

Thanks a lot!




Date Votes
  • Hi Patrick,

    We are facing the exact same situation with EMCO deployment software. Have you managed to find a solution? It would be much than appreciated.



  • Hi Billy,

    Well I did find the cause. It didn't work because at the very end of the installation there's a small window appearing on the client that indicates that the program is finalizing its installation. I think that's why it failed with PDQ because there must not have any kind of pop-up for a silent install to succeed.

    You can still work around this by deploying Antidote as the logged on user in the pdq package properties. I didn't test it thoroughly but I think it works. The downside is that you have to have a local admin user logged on to your client PC so that he can see the small pop-up at the end. The client must also not have any browser of MS Office application running during the setup or the integrations won't work.

    Hope this helps.


  • Hello im trying to deploy Antidote version 10.3.2247

    Have you made any progress on this installation because i have the same problem and cannot install this as the logged on user because they are not admin user... 

    Thanks !