Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

java icon missing after install

Hey guys,

Is it just me or does deploying java from pdq cause the java icon to disappear in control panel in some cases?

It is 32 bit OS win xp / 7. Using msi file from appdata that gets created when setup file is run but not installed.



Date Votes
  • this only happens using pdq deploy? that's strange indeed. 

    i'm using the same msi you're grabbing from the install (Appdata), and have both 32-bit and 64-bit functioning fine. 

    And just checked the Java icon in Control Panel, and it's there and functioning as well. 

    I used the package library as a reference for mine. The instructions in that package closes any opened browser at the time of install. 

    Perhaps someone is leaving theirs on while you're attempting to install? 

  • It's not 100% of the time. I tested it on my pc first. I had my browser closed. It installed & I saw the right version listed in add / remove programs but the icon in control panel went missing. Wouldn't come back no matter how many times I uninstalled & then redeploy with pdq. Had to manually install java for the icon to come back. This isn't the first time I've seen this happen.

    I then tried 2 other computers& they worked fine. So not sure...

  • hmm... i did some research.

     try launching the actual program itself. 

    C:\Program Files\Java\jre6\bin\javacpl.exe

    or C:\program files (x86)

    depending on your version, it should be there. 

    as of JRE7, only the 64-bit will appear. 32-bit is missing. however, the 64-bit icon still appears in control panel.

    64-bit OS will only appear in C:\Program Files\Java\jre7\bin

    Not sure if this was by design, but i looked in my C:\Program Files (x86)\java\jre7\bin and did not find the executable mentioned above. 

    in fact, the bin folder was completely empty. -_-

  • If you are not using the installer from PDQ Deploy Pro Repository, you should allways download the offline installer.

    The current JRE7u11 versions are located here: JRE7u11x86 JRE7u11x64

  • I already have the icon back. I had to un-install & re-install the manual way for things to come back to normal.

    This is a 32bit OS win 7 & the icon does show up when nothing goes wrong. When I was missing the icon I did go to the CPL file in program files & ran it from there. It was just missing from control panel.

    I downloaded the offline installer from

    I just wanted to see if anyone else had noticed this issue. It's fine. I know how to fix it but wasn't sure if I was the only one or not. It also doesn't happen to all computers. Just beware if it comes up again by someone else.