Repository directory is missing

Comments

3 comments

  • Adam Ruth

    Don,

    The repository directory needs to be visible to the background service and it sounds like the credentials used by the background service have been reset to "Local System" so that it's not able to see the share.  We've seen this happen a few times with the latest version when upgrading and we've got a fix for it in the next update to restore the credentials to the proper user.  You can check to see if that's the issue you're having by checking the "Log on" for the PDQDeploy service using the Windows services control panel.  If that's the issue, switch the Log on back to your background service user and you should be fine.

    0
    Comment actions Permalink
  • Don Chino

    Ok, cool beans.

    I was checking the CREDENTIALS settings and that was set to an admin user, but I guess that is for deployments and not the service itself so I never thought to check the Windows Services MSC. I guess the upgrade did change this, because it has been changed to the "Local System" account under the "Log On" tab, so now I changed it back to the admin account.

     

    Thanks and hope the new updates leave this alone during upgrade.

     

    :)

    0
    Comment actions Permalink
  • Adam Ruth

    Don,

    You were correct in thinking that Preferences -> Background Service shows the credentials for the service itself but what it's actually showing is what PDQ Deploy thinks the service *should* be set to not what it actually is.  PDQ Deploy is supposed to change the service if the credentials are different, but the latest version has a bug in it where this doesn't always work so that the Preferences just cluelessly reports the wrong information.

    Unfortunately, as you found out, when this happens PDQ Deploy seems to *almost* work correctly and doesn't give any help as to what's wrong.  Sorry about the frustration, I know how annoying it can be.

    0
    Comment actions Permalink

Please sign in to leave a comment.