Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Java Install Issues

I had a successful installation of Java 7 Update 11, ever since then, any new java version, I get an error.

So I have a few questions:

1) Do I need to uninstall the previous java update before installing the new update?

2) Why am I getting this message box (please see attached file)

This only seems to happen with java, every other program seems to be working fine with the installs and such.

2-21-2013 3-06-35 PM.png


Date Votes
  • Hi Joshua,

    By default when Java is installed it will uninstall a previous version from the same family. This means that Java 7 Update 13 will attempt to uninstall earlier updates in the Java 7 family. It will not attempt to uninstall Java 6 updates.

    We've seen a few other customers have the same issue where Java 7 Update 13 was not able "successfully" uninstall Update 11. There is most likely one remnant of Update 11 on your target computers and this is preventing Java 13 or 15 from installing.

    Go to the Package Library in PDQ Deploy. Download the package called "Java (JRE) 7 Update 15 (32-bit) - ALTERNATE" (see attachment)

    Run this on one of the computers that is experiencing the problem. Note, if that RunDll error window (from your attachment) is still active on a computer it will need to either be acknowledged or the computer will need to be rebooted before a successful install can take place.

    Deploy the Alternate package. PLEASE let us know if the deployment succeeds or if it hangs. If it hangs then we probably need to force remove 13 and 11. I can create the package to do that.

  • Ok great, I'll be testing that out now, thanks.

  • Ok, just a few notes on this. The computer I'm testing this on has Java 7 Update 11 32bit and 64bit both installed. I haven't done update 13, much less 15 yet on it.

    Also, the package hangs at Step 2 (Force Uninstall 11)

    And, I noticed that the interactive service detection box came up again while deploying this package.

  • OK, I will get a new package out there. Gimme a sec.

  • It seems once I closed the rundll box (hidden in the background) it finished the deployment. Is there a way around this? Seeing as we have 300+ computers, it's not really feasible to touch each one.

  • Delete your existing "Java (JRE) 7 Update 15 (32-bit) - ALTERNATE" package. Save the attached XML file to your computer and import it into PDQ Deploy. To Import go to File > Import. When you open the new package it should look like the attached image.

    Please run this and report back.


  • Great, will run it now.

  • Ok seems to be working perfectly for 32bit.

    Do I just need to run the 64bit version of the install package now? Seeing as you included the delete uninstall for update 11/13 64bit keys.

  • No, the 64 bit installation is probably fine. Please note, this doesn't delete the 64-bit keys. It only deletes the 32-bit keys on 32 OR 64 bit machines. A 64-bit Java deployment will add an entry to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall. This is why when we removed the key from this path we specified that it only run on 32-bit systems. The 64-bit steps delete the 32-bit Java keys from HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall.

    Thanks for getting back to us. I will add this new Alternate package to the Package Library.

  • Ah ok, that makes sense. Thanks a lot, appreciate the speedy responses.

  • I ran into this exact same problem except that I have 125 computers all running Java 7u45 and I am trying to update to Java 7u67. About 20 computers installed correctly, but all of the rest failed.  While trying to figure out why, I pushed install on one computer and I see the "Interactive Services Detection" window start flashing at the bottom of the screen.  So after googling I found this article and I copied what they did here by editing the normal Java Install Package.  I added a command line to kill the old install process (since it would hang indefinitely on the remote PC), then I added a command line to remove the Java 7u45 and 7u67 registry keys.  I found the keys by comparing to the keys listed in the XML attachment Shane Corellian has above to they keys on the remote computers registry. Then, I added the command to uninstall both 7u45 and 7u67.  After that, the install of Java 7u67 worked on the majority of computers but still had to manually install Java about 20 computers. 

  • I am experiencing the same issue with 400+ deployments - it hangs on the installation of Java until it times out - we are going from Java 7u65 to Java 7u67.  What do I need to change to get past the error?  Thank you!

  • Hi Marc,

    Are you deploying the Java 7 u67 Alternate package that we have available in the Package Library?  If not, download the alternate package and deploy it to the machines giving you trouble. The Alternate Package performs a clean install of Java, which should resolve the error you are seeing when deploying Java in your environment.


  • Hey Marc,  Brandon is correct.  I'm the one that posted right before you did and after I figured everything out and created my own custom Java install, I called AdminArsenal next day and they suggested the Java ALTERNATIVE package.  I looked at that package and discovered that it contained everything that I had to figure out manually.  Mainly, the "Kill previous java install" along with deleting the reg keys and uninstalling old version and the current version since it was half way installed on all of our computers.