(Q)Office 2013 Silent Deploy

Comments

10 comments

  • Shawn Anderson

    Yes, you can pass a config file using PDQ Deploy. Be sure to check the "Include Entire Directory" checkbox in the PDQ package that you create. This will copy all files and subdirectories around your setup.exe. The config.xml will be at the same level as the setup.exe. So in the Parameters field in PDQ, you simply call it without any path info.

    /config config.xml

    0
    Comment actions Permalink
  • Jason Braverman

    That should be fantastic.. almost ready to deploy it.  I will report results.

    0
    Comment actions Permalink
  • Jason Braverman

    Seems to be working.... I did have to change the path to use the setup.exe in the x64 dir and not the main setup.exe, as well, I had to modify the registry on Win7 to allow me to access the admin$

    1. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.
    2. Right-click in the pane on the right side and add a new DWORD (32-bit).
    3. Give the new setting the name LocalAccountTokenFilterPolicy.
    4. Double click on that setting and give it a value of 1.
    0
    Comment actions Permalink
  • Jason Braverman

    Failed after 1 hour.  No explanation other than it went over the time needed.  I sent a report to support.  Any other suggestions?

    0
    Comment actions Permalink
  • Shane Corellian

    Ahh yes, that would be Remote UAC. You would be getting an Access is Denied error very early in the deployment if you ran into that. We should try and make this info a little easier to find. It has been documented at the link below.

    http://support.adminarsenal.com/entries/20828513-Can-t-access-the-ADMIN-using-a-local-user-account

    0
    Comment actions Permalink
  • Jason Braverman

    Thanks, I also found that on Windows 7 Ultimate SP1 I also have to remove the computer from the Homegroup and reboot before this would work.  I am not sure if this applies to other versions of Win 7.

    The install, however, did not complete as noted above even with complete access to the Admin$

    0
    Comment actions Permalink
  • Sam D

    Has anyone been able to figure this out? I have tried multiple ways and can't get it to work. The funny thing is the command will work if I log into a computer and paste it in a command prompt. However, PDQ Deploy just keeps running until it times out.

     

    This is the normal command to setup the Click-to-Run application

    "[UAC path to folder]\setup.exe" /configure "[UAC path to folder]\config.xml"

     

    Also tried deploying the Setup.exe with the entire directory and "/config config.xml" as a Parameter. Same thing.

     

     

    0
    Comment actions Permalink
  • Sam D

    Sorry I guess Jason's link is actually for an MSI install.

    I am trying to get the Click-to-Run version installed for Office 365

    0
    Comment actions Permalink
  • Aydn

    Hey Sam, did you have any success with Office 2013 ProPlus Click to run? 

     

     

    0
    Comment actions Permalink
  • Sam D

    Yes, I just have command step with this command:
    \\PATH\installdiroffice$\setup.exe /configure "\\PATH\installdiroffice$\office.xml"

    I also have a shortcut with this command next to the setup, so I can make sure it works before using PDQ deploy. If I have a machine that times out, running the shortcut will show the error.

    I'll attach my office.xml. Make sure the path in the XML is correct!

    I had errors when the Access 2007 and 2010 database engines being installed, since they are 64 bit and I'm installing the 32 bit version of office; so I have steps to uninstall them first.

    Lastly for safety, I have a command step that double checks that the shortcuts are on the Start Menu after it's installed:
    IF NOT EXIST "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft Office 2013\Word 2013.lnk" EXIT /B 1

    I've also done the same with Project and Visio, they just need their own xml files and can be run after installing office.

    0
    Comment actions Permalink

Please sign in to leave a comment.