Deployed PDQ Package Show Status = Successful, but installation didn't start

This problem popped up a couple of days ago.

Packages that used to work don't work anymore. They show the Status "Successful" after 4 seconds.

One package contained a Step to run a Install-Batch for Microsoft Navision, the other one should set up dotnet 3.5 in silent mode. both packages terminate after a couple of seconds and give back succesful without really doing anything on the target computer.

on the target computer i see the PDQ deploy service running, but it just disappears after a couple of seconds without starting the setups...


PDQ Deploy 2.2 (Release 2)



Date Votes
  • Marc,

    i saw this today by us on a Batch Script Installation of MS patches. I send the Installation to 30 machines and on only 25 machines the Installation works fine on the other 5 machines came directly Status succesful, but on this machines never happend anything. i tried again on the 5 machines the same installer and on the second try the Installation runs 100%ig. i saw this issue the first time on pdq deploy 2.2 (release 2) and never before. and we changed nothing on the installer package.

  • Yes I tried several times as well to no avail =(

    Funny thing is, the Microsoft Dynamics package does function when deployed as part of a stacked package. That's some interesting behaviour....

  • Thank you for letting us know.  Can you export the packages and send them in?  There may not be anything particular about them triggering this issue, but it's always possible.

  • Did it work properly if you retried the deployment? Doing some research on this we have seen this happen in a handful of cases where the application was missing a prerequisite and would return with a 0 error code making it appear that the software was installed. 

  • Yeah my bad...after installing .net 4 it worked like nothing can stamp this as a user error :)

    thank you for your help and thanks for this great great deployment/inventory tool!

  • No worries, sometimes it tough to tell where the problem lies. What was the application?  Just in case anyone runs into again we can point them in the right direction.

  • Microsoft Dynamics NAV 2009 R2


Please sign in to leave a comment.

Didn't find what you were looking for?

New post