Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

PDQ Deploy fails to remote install application that installs locally

Hello, I am having trouble deploying a custom software package. I need to install a program called riversoftofficesetup.exe. After setting up the package and running it, it hangs on "running" indefinitely. I know the remote install to this computer works as I was able to remotely install Java using PDQ. While sitting at the console of said computer I ran the same command "\\server\share\riversoftofficesetup.exe /silent /NORESTART" and it installed just fine.

Any ideas why PDQ can't remotely install it? As stated above, PDQ can deploy JAVA so I know it is not an access problem, and the command listed above works fine when using the local run dialog.

Any help would be appreciated, thanks.


P.S., I have added screen grabs of the package setup and the command run on the local machine. I am currently using PDQ Deploy version

PDQ Deploy 2.jpg
PDQ Deploy 3.jpg


Date Votes
  • Thanks for the screenshots and props for testing the command line switches via the Run window.

    When you ran this locally did ANY window (other than a UAC confirmation) pop up? A common window (even in some "silent" installations) is either a confirmation window or an Installation complete window. 

    Are there multiple files that are needed for the installation? If so, are they included in the package? Extra files are usually included by clicking the Include Entire Directory option but they can also be added via the Additional Files drop down.

  • Shane, thanks for the reply.  When run locally I did see a progress bar display but that was it.  There were no confirmations or installation complete windows.  The only file needed is the executable.  I was made aware of another option to use, "/verysilent" which will not even show the progress bar.  I could try that?

  • Definitely try the /versilent parameter. Sometimes even a progress bar can prevent a windows service (the PDQDeployRunner-x service installs the product on the targets) from finishing a deployment.

  • I tried the /verysilent option.  When run on the local machine it does not show the progress bar or anything else.  I then uninstalled the program and tried using PDQ with the new option and it did the same thing, hang with a running status.  Anything else I could try?

    I did not know about PDQDeployRunner-1 service.  It is currently started on that machine.  The PDQ console is showing a runtime of 9 minutes and still running so I will now abort the deployment.  FYI, when run locally it takes about 20 seconds to install.

  • I found a workaround.  I created a batch file that does the install then pushed the batch file using PDQ and it worked.  Thanks for your time.