Just bought PDQ Deploy, having issues with our first application deployment.

I'm trying to create a new package for deployment using this software: http://www.sstsoftware.com/products-services/sst-summit/

Right now I'm just trying to get it working with the free trial off the site and I'll worry about registration after the install.

The file comes as a setup executable which can be extracted to its msi components via command line "summitsetup.exe /extract".

So now that I have the msi installer, I ran setupsummit.msi /? and got the list of supported switches. It supports quiet install as well as a passive install (unattended with progress bar).

So I started up PDQ deploy and created a new package pointing to my msi installer file. I've tried using the auto generated command line and custom command line but every time I go to deploy it, it fails with "MSI Error 1603: Unknown error 1603".

 

How do I proceed from here? Does anyone want to download the trial off that website and give it a go?

0

Comments

3 comments
Date Votes
  • You shouldn't have to add the silent parameters. We do that by default for MSI's. NOTE: the installation will run in the background so selecting the passive will not actually display anything on the user system. Please remove the parameters and use the default settings in PDQ to run it silently. Let's see if the 1603 still crops up.

    0
  • Yes thank you, I got it working. Incidentally I forgot to add the .cab file from the extracted .exe which was the main issue but I did change the msi options to use the default as well and it installs flawlessly on the machine. However, another issue has come up. The application uses UAC patching for updates and there is an update immediately after running the app the first time. When the update attempts to patch I get this:

    http://support.adminarsenal.com/attachments/token/k5nxticzsqgmrf7/?name=error.png

    A box then prompts to browse for the msi. I can do that but if I'm deploying this app to our local users, this won't be ideal. Is there any way to get the package to not delete the local files from "C:\Windows\AdminArsenal\PDQDeployRunner\service-1\exec" on completion?

     

    0
  • To remedy this issue, you will need to write a batch file to copy the msi and associated files to a different location.  Once the file have been copied have the batch file execute the install from the new location.   You can use an install step in PDQ Deploy to execute the batch file on the target machines.

    The application will look to this new location when it is run for the first time.

    Hope that helps.

     

    0

Please sign in to leave a comment.

Didn't find what you were looking for?

New post