Error when launching PDQ Deploy

Comments

17 comments

  • Shane Corellian

    Hi Raiden,

    Is there an event in the Windows Event Log? If so, we'd need to see it. Hopefully there would be a stack trace pointing us in the right direction.

    What O/S is this running on? 

     

    0
    Comment actions Permalink
  • SelfMan

    I suggest you visit Aaron Stebners' site and download the dotNet Setup validator and validate your dotNet installation.

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    0
    Comment actions Permalink
  • Raiden Knightlore

    Hi Shane

    I have been through all the registry logs and can see nothing which relates to PDQ Deploy (at least not by name) or even the time stamp of when it was launched?

    I removed all entried from the Regsitry too, reinstalled and ran the app but still I get the same error?

     

    I have attached a screenshot of what I am seeing

     

     

    0
    Comment actions Permalink
  • Raiden Knightlore

    Hey Selfman,

     

    Thanks for the tip, I ran the .NETvalidator and ran it for each instance of my installed .NET's and each was completed successfully?

     

    Many thanks

    0
    Comment actions Permalink
  • Raiden Knightlore

    Hey Shane,

     

    Oopss forgot you asked what OS I am on

    Windows 7 Enterprise x64

    Intel i5

    16GB Ram

     

    Thank you

    0
    Comment actions Permalink
  • SelfMan

    This issue is caused by a registry key permission problem.  To fix it, try:
    1.open regedit
    2.right-click on HKLM\Software\Microsoft\Admin Arsenal\PDQ Deploy and click permissions. You will get a warning that the security information is incorrect and you get a button labelled "Re-Order". Click this and the security information then shows up as usual.

    Verify the other Admin Arsenal keys too...

    0
    Comment actions Permalink
  • Raiden Knightlore

    Hey Selfman

    I dont have an entry at that location for Admin Arsenal?

    I did have an entry at HKLM\Software\Admin Arsenal\PDQ Deploy which has no issues when looking at permissions, I gave the hive full perms but still I get the error when I try to launch the app,

     

    Thank you

    0
    Comment actions Permalink
  • SelfMan

    Ok, then check also HKCU\Software'Admin Arsenal subkeys.

    If that does not help, login under a different account with administrative rights and try it again.

    0
    Comment actions Permalink
  • Raiden Knightlore

    Hi,

     

    I look at HKCU\Software'Admin Arsenal subkeys and reapplied the perms, there were no issues with them and  I didnt get any popup boxes.

     

    I also logged on with another admin account and did the same but it made no difference?

    Thank you

    0
    Comment actions Permalink
  • SelfMan

    I memt to log in as a different user and run PDQ Deploy. Not the regedit.

    0
    Comment actions Permalink
  • Raiden Knightlore

    Hi

    I did that at the same time as I looked at the reg keys and I got the same message about the Access Control List

     

    Thank you

     

     

    0
    Comment actions Permalink
  • SelfMan

    Have you tried to reinstall PDQ Deploy? I think there is something wrong with your registry.

    There is one way to repair th registry access permissions, but its a "last resort" solution and I strongly reccommen to backup first.

    For that you need the secedit and subinacl tools. AGAIN I strongly advise for backup.
    This procedure CAN break your computer if its not executed properly.

    secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose

    rem cd /d “%ProgramFiles%\Windows Resource Kits\Tools”
    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f
    subinacl /subdirectories %SystemDrive% /grant=administrators=f
    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=system=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=system=f
    subinacl /subdirectories %SystemDrive% /grant=system=f

    0
    Comment actions Permalink
  • Raiden Knightlore

    Hi

    Yes I have tried installing PDQ Deploy multiple times, after uninstalling the previous installation.

    I was thinking last night, I have PDQ Inventory installed as well but havent not tried running it since I had the PDQ Deploy issues.

    I have just launched the applicaition and this now fails we well saying "no such table: settings"

    I will remove both together thins time and then reinstall both...

    The above reg access permissions solution are you saying this could goose my entire laptop or just the PDQ Deploy?

    I image my laptop regularly with the most upto date image being taken only a couple of days ago

     

    I will now uninstall both apps, reinstall them, and post back.

     

    0
    Comment actions Permalink
  • SelfMan

    it looks like the database itself is damaged. You should run checkdisk anyway.

    When you uninstall both PDQ Deploy and Inventory, dont forget to remove the residual data from C:\ProgramData\Admin Arsenal

    The reg access commands reset the registry permissions to default values. (like a new installation) It does not remove any entries, it only changes the permissions. But as allways with registry, there is allways a risk that something goes wrong.

     

    0
    Comment actions Permalink
  • Raiden Knightlore

    Success.....

     

    Ok so I uninstalled PDQ Deploy and PDQ Inventory and then removed the residual data folder from C:\ProgramData\Admin Arsenal.

    Reinstalled PDQ Deploy and vloila it launched fine and went through the initial setup......

    I havent reinstalled PDQ Inventory yet but will post back when I do..

    Many many thanks to you guys for taking the time to help me out, its very much appreciated....  I guessing a corrupt PDQ Inventory might have been the root cause?

    Thanks again

    0
    Comment actions Permalink
  • Raiden Knightlore

    I have just reinstalled PDQ Inventory and this is now working too.

     

    Thanks guys

    0
    Comment actions Permalink
  • SelfMan

    Ok thanks for letting us know. I still recommend to run the checkdisk and other diagnostic tools on the drive. Files don't  get corrupted just so and neither the ACL on the files.

    0
    Comment actions Permalink

Please sign in to leave a comment.