Important Notice: On February 29th, this community will be put into read-only mode. All existing posts will remain but customers will be unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Windows Essentials (Movie Maker)

Hi, I'm a newb to this app and I'd like to know what I'm doing wrong to silently install Windows Essentials from PDQ Deploy.

I have a network domain environment where I'm trying to deploy to 40+ workstations.  I have admin rights and just use the following package settings (please see attachments).  When I attempt to deploy, I get the following errors (attachment).

I have already tried using /S, /s, and /qn.  It only works with /silent when I'm actually logged into the workstation with my credentials (obviously, defeating the purpose).Any advice would be appreciated.

PDQ Package Settings.png


Date Votes
  • There are usually dependencies for Windows Live. Are there any other files needed during the install? If so you'll need to click the "Include Entire Directory" check box. With PDQ Deploy, even though you are specifying a network share, all the install files specified are copied locally to each target before the installation begins. Checking include entire directory tells PDQ to copy everything in the same directory or lower to the target before starting the install.

  • Hi Shawn,

    Basically, this is what I have now: (see screen shot).  The '/s' does not work, but '/silent' does.  Otherwise, it just hangs.

  • Try combining Movie Maker to a single string (MovieMaker).

    ProdID’s for the command line:


  • My co-worker is just decided to basically copy all the install files (including the DLL files installed in other areas of the C drive) and repackaged it!! lol

    Counter-intuitive, yes, but there's got to be a way to get this working!!!  The moviemaker string didn't change anything..something else is going on.

  • The associated files are only 2MB in size. It seems like that is too small. Are there other files needed for the deployment that are not in the directory where the setup exists? If they live somewhere else you would need to specify the location in the add files section. Remember, PDQ Deploy copies all files specified to each target and then starts the installation locally on the target. 

  •'s the deal:  I went ahead and deployed it to my machine under my admin account from a user account (non-admin) AND it worked!  Please note new config package details. 

    For some reason, it worked liked a charm without 'Entire Directory' option.  Now I'm going to try it on a remote machine again.  If it doesn't work, then I know it has something to do with the background runner process on the remote end. 

  • Ok, so now there was a file missing, but the shortcut links, etc were loaded.  Probably a network foulup, but it far

  • Ok, so now there was a file missing, but the shortcut links, etc were loaded.  Probably a network foulup, but it far

  • If I recall correctly there are two different versions of the install software from Microsoft.  One is a wlsetup-web.exe and the other is wlsetup-all.exe and you'll want the latter.  The deployment job I made last September for my staff I wanted ONLY Movie Maker and Photo Gallery and here is the command line I used and it deploys perfectly. (version 16.4.3508.0205)

    wlsetup-all.exe /AppSelect:PhotoGallery,MovieMaker /noceip /nohomepage /nolaunch /nomu /nosearch /notoolbarceip /silent

    Hope that helps.


Please sign in to leave a comment.

Didn't find what you were looking for?

New post