Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

MSI Error 1603: Unknown error 1603


after i have updated pdq deploy to i got on every package the same error. The packages are used on a few Computers without any Problems. What happend with the new version ? No virusscanning software is running on server and client.


thank you for your help






Date Votes
  • Hi Claus,

    Possible Causes

    A file that was needed for a successful installation was not found or was inaccessible. 

    Error 1603 is a catch-all error used by Microsoft Installer when an unexpected failure is encountered during an installation. Quite often this occurs when a file that is needed for an installation is not found (perhaps it was deleted by an antivirus solution or it can't be accessed on a network share)

    Target computer may need to reboot after applying Windows updates. In these cases Windows may not allow additional MSI installations until the target has rebooted.

    How long has it been since the target machines were rebooted?


  • Hi Lex,

    at first thank you for your fast answer. This is not a special machine and a testmachine was reboot a few minutes before installation. I have found an older version of PDQ Deploy on my harddisk. After the installation everythink works great again. One solution i have found in the new version is that you have to change the copy mode from push to pull. After that configuration it works without failures, too.

    Maybe a bug ?



  • Hello Claus,


    Could you say me where you have the option "Push to pull" please, because i have a same error (1603) but it's not my antivirus. And when i put the option "Include Entire Directory" is 30% better but not 100% !

    Thanks to help me

  • Hello Dimatrio,

    this option is only availiblie in the Pro-Mode Version. If you have the pro Version you can Change it in your package properties of each Installation package. You can Change it anywhere (i dont know where)  for your Standard copymode , maybe.

    I hope i can help you with this.