Why is my removal of LightScribe generating errors?

I am removing LightScribe from 2000 computers. This was a preinstalled piece of software but is never used. On my test machine I run my removal process and it works fine. However, when I run it against other systems it's never successful and just generates the following errors (1605 & 128). The package only has two lines and they are:

  1. Step 1 - Kill running LightScribe process
  2. %WINDIR%\System32\taskkill.exe /f /im LightScribeControlPanel.exe
  3. Step 2 - MsiExec.exe /qn /norestart /X{07E49BC1-24FF-4D7A-AC74-727BE95801AF}

I'm basing this on the removal process information I pulled from the registry.

InstallLocation: C:\Program Files\Common Files\LightScribe\
ModifyPath: MsiExec.exe /X{07E49BC1-24FF-4D7A-AC74-727BE95801AF}
UninstallString: MsiExec.exe /X{07E49BC1-24FF-4D7A-AC74-727BE95801AF}
Process to Kill: LightScribeControlPanel.exe
PID: 1060  LightScribeServices

MsiExec.exe /qn /norestart /X{07E49BC1-24FF-4D7A-AC74-727BE95801AF}


Any Idea's on why this is happening?



Sample Deployment Screen.pdf


Date Votes
  • Mark error 128 as successful in your Success Codes for your Taskkill.exe step. Error 128 means that the process you were trying to kill wasn't running.

    Error 1605 is a Windows Installer error which means the specified product you are trying to uninstall doesn't exist. This also needs to be added to the Success Codes field of your Uninstall step. Generally the Success Codes you want when you attempt to uninstall a product via MSI are:

  • Thank you. I will add those and continue testing.


Please sign in to leave a comment.

Didn't find what you were looking for?

New post