PDQ Deployment stuck on Connecting status

Hi PDQ community,

We are using PDQ very frequently and none of my colleagues ever had this problem.

PDQ gets stuck on Connecting while deploying and then I have to manually abort the deployment, which is a very time consuming work around with over thousands of clients. It's not on every computer but only every 50-100 computers.

I tried to resolve this problem with disabling the Service Manager TCP connection, but it didn't help.

Thank you for your support.

0

Comments

12 comments
Date Votes
  • This problem can pop up every now and then. It is fairly rare and "the perfect storm" of certain events need to happen to cause it especially in later versions of PDQ Deploy.

    The easiest thing to do is to clear out those computers that are stuck in a Connecting state. Go to File > Preferences > Database. Open your SQLite Console. Type in the following command (dont forget the semicolon):

    delete from DeploymentComputers where Stage = 'Connecting';

    Then go to the Background Service panel (in Preferences) and stop the Background Service. After doing this go ahead and close and reopen the PDQ Deploy console. The Background Service will then start automatically (when the console is started). This should take care of the problem.

    1
  • Hey Shane,

    Thanks for your quick reply. It worked! :-) But only after I restarted the deployment machine.

    Cheers,
    Umut

    0
  • Thanks for getting back to us. I modified my statement to have you stop the Background Service. Doing this should prevent you from having to restart the console computer.

    0
  • Thanks for the great support you guys are offering, some other big companies could learn a lot from you guys!

    There is still an issue coming up though with the status stuck on connecting again after a while.
    I think if there was an option that if a status like Connecting lasts longer then 30 minutes it should let the deployment fail it would be great to get around this problem. Is there already a way to configure this? Or would this be a feature request?

    0
  • What version of PDQ Deploy are you using? What are your Offline Settings (Preferences > Deployments). Are the computers (that are stuck in the Connecting state) powered on? Are you using Wake-on-LAN?

    0
  • PDQ Version: 4.2.0.0 Release 2 Enterprise Mode

    Offline settings: http://imgur.com/NFU2lZ3

    I think I see the problem now...it's the 72h setting.

     

     

    0
  • I took the offline setting out and there are still some computers where the "Connecting" is stuck. The computers which are stuck are online (Tested through pinging)

    0
  • Thanks, Umut. We are going to try and duplicate the issue in our lab.

    0
  • Umut, some issues were recently fixed that may very well solve this problem. They will be available in PDQ Deploy 5. It is in a public beta right now.

    0
  • I am experiencing this issue also.  The clients are directaccess connected workstations.  I can ping all of them.  Currently only 1 workstation (shown below) out of 6 has reconnected after a reboot.

     

    0
  • Do they get the same IP address when they come back up?

    0
  • Yes - also since they are connecting via DirectAccess they are IPv6 (although I don't believe that is the issue).  I am able to abort and simply perform the 3 step in another package (but that defeats the purpose of automating it).

     

    0

Please sign in to leave a comment.

Didn't find what you were looking for?

New post