Share a single database?

Comments

5 comments

  • Shawn Anderson

    Jame at this time this is not possible. We are strongly considering this but at this time each console will maintain it's own database. 

    0
    Comment actions Permalink
  • Joshua Floyd

    Just wondering if this is going to be made available soon?  I see in the release notes for V8.1.0.0 there is a brief line about shared databases:  "* Shared database version and compatibility warnings added to Shared Databases page."  I do not see an option anywhere to add/configure a shared database, at least not with the Enterprise version.  http://support.adminarsenal.com/entries/98783967-Version-8-of-PDQ-Deploy-Released

    0
    Comment actions Permalink
  • Michael Muni

    in preferences there is a sharing section. this it to share your database with other installs, however they have it locked down so that only customers with Multiple Enterprise licenses on the same account can use it.

    0
    Comment actions Permalink
  • Jon McNamara

    I would be extremely interested in having a single database shared between multiple installs of PDQ Inventory & Deploy.

    At the moment, I have an Enterprise x 3 license but have a single install on a server and use RDP to access both Inventory & PDQ for multiple users. This allows us to all use the same database and we can all be running the software at the same time doing different things in it.

    We have never had an issue with this setup but I'm wondering what your thoughts are?

    0
    Comment actions Permalink
  • Brian Camp

    Jon,

    Since you've got a license for each individual user, you should be able to set it up like how we're using it.  We've got 6 people that work in Deploy, and 7 that work in Inventory.  Here's how our setup works --

    Main deployment server has got Deploy and Inventory installed.  This is the server that holds the software repository and reports.  I build all of our packages and import from the library from here.  I use RDP to work from this server, but I'm the only one.  The reason I do RDP is because Deploy consoles activated with the same user email won't see the shared database.

    Each tech has got PDQ installed on their desktops.

    From the main server's Deploy, File -> Preferences -> Sharing.  Tick the box to share your packages, you can also tick the second box to use any packages your other techs might be sharing.  Path is just the UNC path to your repo, and I'd recommend changing the title to something everyone will recognize.  It defaults to the hostname, IIRC.

    From the main server's Inventory, File -> Preferences -> Scanning.  Tick Read From Cache (optional, helps with system load), and Write To Cache (not optional).  Path again is just a UNC path to your database.

    That sets up the sharing for others to connect to.

    For the technicians to use the shared packages from their desktops, first, they have to be activated with their own email address.  Then back to File -> Preferences -> Sharing.  They'll tick the box to access shared packages.  We use the same UNC path on their client machines.  I don't think it's necessary for the Path to match on their clients to use your packages, but if their repo is local to their machine, they've got to worry about keeping their files backed up.

    For Inventory, again, activate with a different email address than the main server.  File -> Preferences -> Scanning.  Tick the box to read from cache, and the box to use cache exclusively.  As long as you leave Write to Cache unticked, their desktops will never do their own scans.  Scanning can really bog down a machine, our guys leave that box unticked and don't let their machines do any of the scanning.  YMMV.  The UNC path to the Inventory database needs to match what you've got on the server.  

     

    Getting the sharing set up and working just right can be a little tricky.  It won't show up immediately after hitting the save button, but you should start seeing shared databases pop up on the left hand pane after about 15-30 seconds if things are set up correctly.  Hope that helps.

    0
    Comment actions Permalink

Please sign in to leave a comment.