Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Why do I get "File Not Found" when adding an MSI to a package?

Oddly this used to work. I just noticed it is now broken.

I browse to the MSI under Install File in the Details tab but I get File Not Found under File Details.

If it matter this is on DFS. I am not having this issue with other packages.



Date Votes
  • Hi Jericho,

    What version of Deploy are you currently running and can you provide some screenshots of the deploy package step and what you're seeing?

  • 7.1 Enterprise


  • The file appears to be corrupted. I have asked the admin to grab a fresh copy. I'll let you know if that resolves it.

  • Well. We made no changes but it seems to have resolved itself.

    I hate those.

  • Hi Jericho,

    Glad it resolved itself.  It sounds like the program was having an issue checking the existence of the file (even though you can browse right to it) and the file checking isn't set to run all the time.  Whatever triggered the check again must have solved it.

  • Hi Jason,

    It has returned but with a different package that is pointing at a batch file. This package has not been updated in weeks. I know you had sent me an email with a link but I cannot find it.

    Can you resend that?


  • Thanks for the link. A restart of the service resolved it. Odd but it is a easy fix.

  • what service did you restart?  I have been having an issue similar to this, my repository is a DFS share and sometimes it will not be able to locate the files either.

  • I was having this issue and they sent me a beta build that had a refresh menu that solves this.

  • Same issue here !

    Just after an update with the GUI ("Check for new Version") it just happened to me:
    * all MSI Files are stored with UNC /SMB Share

    * after Upgrade to version 8 ALL my custommade previously working MSI/exe Packages got this error : " file not found"

    ** facts:

    *** packages (innosetup/exe and MSI)  so far are stored  in a CIFS/ SMB Share , access is permited for the pdqdeploy serviceaccount ,
    **** deployment worked like a charm for most of the packages previous to update (i just started testing PDQ Deploy and am happy so far!)

    **** it seems that the inplace upgrade of pdqdeploy just damaged my custommade packages - the package "Visio Viewer 2010" which is part of the pdqdeploy hosted free packages STILL works... As you can see in Pic 08_54_20-clipboard:


    What I´ve done so far to find a solution:
    * Update to current release of beta Version 8

    * rollback from beta branch to Version 8.1.00 (Free Version, but I´m gonna buy it this year i think - good work!!!)


    So whats next? Any help highly appreciated :)

    Cheers , daniel

  • I restarted the PDQ Deploy Service.

  • Okay , so ..

    Solution was to check again the credentials used for Service,

    * rechecked Account used for pdq deploy service

    * restarted service


    Working like a charm, again so far :)

  • Dont think, that was it. as I had that problem and it was not credentials and it would come and go so your restart may have been what fixed it for now.

  • @Daniel thanks this works for me!