Deploying Office 2016 via a Cmd call to .MSP failing

So Im trying to push O2016 via a custom .MSP and it's essentially timing out. My package has two steps: Step 1-Call Installer.

Install file is located on the network: \\netapp\software\office2016\64\setup.exe

Parameters: /adminfile MI-Office.MSP

CommandLIne: setup.exe /adminfile MI-Office.MSP

I have tried both checking and unchecking the Include entire dir box. 


Under Conditions I have only Workstations OS's selected and under Options I have it set to runas my Deploy User which is a Domain Admin, and Local Admin. *via GPO to every workstation.


Step 2 is a Reboot.


Now when I deploy the status on the console is stuck on Running.  If I browse to the debug log on the client I can see it successfully calls setup.exe /adminfile MI-Office.MSP however it sits there waiting for process to end.  Nothing nowhere lists the process its waiting on.

I can run this installer manually via a batch file and it works perfectly.  How can I determine whats going on here?





Date Votes
  • Hi Ben,

    Take a look at this article that is a step by step walkthrough and see if you missed something.

  • That's the exact article I used.

  • Just went back through it.. created a new MSP, new deployment package.. installed and installing Office arch are both 32-bit.  Same stupid results.. 'Waiting for process to end".....

  • Hi Ben,

    I'm not sure if you were able to resolve this, but one thing that frequently works in cases where the install times out is to change the Install/Command step (depending on the Office version) > Options tab > "Run As" to Deploy User (Interactive). Sometimes "Silent" means only mostly silent and not for-sure-super-silent.


  • Hi Ben and Brigg,

    I have exactly the same problem. I've followed the same article and when I want to deploy it, it's "Waiting for process to end" until it times out. If I change the "Run as" to Deploy User (interactive) instead of just Deploy User, The setup starts but not silent!

    Ben, did you manage it to get it running (silently)?


  • Hi Lars,

    Were you able to run your O365 install command as a batch file locally on the machine using UNC paths and have it install correctly like Ben?

    Also, when you run the deployment as Deploy User (Interactive), what non-silent dialog boxes do you get? What are your OCT settings for "Licensing and User Interface"?

  • Hi Brigg,

    It's the O2016 version and not O365. I found (in my environment) the problem and for now I've made a workaround for it to continue.

    The problem was that I had also combined the Multi Language Pack and Proofing tools in the original custumized deployment. So whenever I tried the silent install, it was always asking what I wanted to install (O2016 or Language Pack or Proofing tools). So every client was waiting for input...

    I did changed it to Deploy User (interactive) before I saw this dialog box popped up.
    My OCT settings for LUI are: Use KMS client key, accept terms, display level None, Suppress and no cancel.

    In the end I removed the MLP and Proofing Tools from the customized deployment and made a multistep install with PDQ.

    Step 1 install O2016 with customized deployment (Dutch)
    Step 2 install O2016 Multi Language Pack (English)
    Step 3 install O2016 Proffing Tools (all languages)

    The only problem I'm dealing with is activating through my KMS (2012R2) (not enough licenses for KMS, but I have 60!).

    Cheers Lars


Please sign in to leave a comment.

Didn't find what you were looking for?

New post