Filter not working correctly?

Comments

11 comments

  • Adam Ruth

    Are you trying to show all of the computers that don't have the "C:\Program Files\McAfee" directory?

    0
    Comment actions Permalink
  • Jprater

    Yes, I want to show all the computer that are physically missing that directory.

    0
    Comment actions Permalink
  • Adam Ruth

    Did you mean that you have File Path Name DOES NOT CONTAIN "C:\Program Files\McAfee"?

    If so, then this is going to match for any file in the database that isn't in the McAfee directory.  What you want to do is to have the filter Not Match All rows where File Path Name Contains "C:\Program Files\McAfee".  I've attached an report which you can import into your database, it'll make it more clear.  It can get a bit confusing when mixing different "not" operators.

     

    0
    Comment actions Permalink
  • Jprater

    I imported your report and it's still listing all of the computers. :( I think I even did it the way you had it thinking it would work.

    0
    Comment actions Permalink
  • Adam Ruth

    Can you verify that your inventory database has files listed for the McAfee directory?  It may be an issue with scanning for files in there, since the report only goes off of the scanned inventory data it will look like no computers have the McAfee directory if there aren't any files in the database.

    0
    Comment actions Permalink
  • Jprater

    I just opened up 10 Latitudes and 3 of them were missing the information (b/c they are turned off). These machines, however, are showing up on the report.

    0
    Comment actions Permalink
  • Adam Ruth

    Where the 7 other machines showing up on the report?

    0
    Comment actions Permalink
  • Jprater

    Yes, the 7 other machines are showing up in the report. In fact, I think every machine that is a Dell Latitude is showing up in the report.

    0
    Comment actions Permalink
  • Adam Ruth

    Would it be possible for you to send me your database?  I haven't been able to duplicate the issue here in our lab, so I'm sure I've got something that's different than what you have.  If not, can you export the report and send it in?  Perhaps something happened to it when it was imported.  Just send them to support@adminarsenal.com (or I can get you an FTP or Dropbox folder to upload them).

    0
    Comment actions Permalink
  • Adam Ruth

    Thank you for sending in your database.  I was missing something obvious, my file scanners were only looking for McAffee, not other files.  Sorry about that.

    It looks like there is a problem with the reports.  It's not a bug as much as a hole in the design.  Reports can't do what you're trying to do, I've added to our roadmap to get that fixed (we're revamping report and collection filters in a future version).

    To get what you want you can either do an SQL report or use nested collections.  I've attached examples of each for you to import.

    0
    Comment actions Permalink
  • Adam Ruth

    And here's the collections.

    0
    Comment actions Permalink

Please sign in to leave a comment.