pdqinventory using 100 percent of processor.

Comments

1 comment

  • Shane Corellian

    There are a few things to look at.

    How many computers are in your database? How much RAM is on the console computer? What O/S are you using? 

    If the number of computesr is greater than ~700 you may want to increase your Heartbeat interval from 300 seconds to 600. If you have thousands of computers then you should probably consider having your heartbeat set to something like 1800 - 3600 seconds. You can set the Heartbeat in your Preferences window.

    How often are scans scheduled? You may need to adjust these schedules as well.

    If you have a lot of Active Directory OUs (that contain computers) you will want to be running the latest version of 3.0 Release 6.

    Try this: Go to File > Preferences > Database. Open a SQLite Console. Type in the following SQL command.

    select count(*) from CollectionComputersRefresh;

    What number was returned? If the value is in the thousands (definitely if the value is higher than 100,000) then you will want to clear that table. You can run this command to do that:

    delete from CollectionComputersRefresh;

     After you run the "delete" command close and reopen your console.

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.