PDQ Inventory stuck on "Connecting" or "Queued" status when scans start

Comments

7 comments

  • Brandon Rewis

    Hi Ryan,

    You mentioned the machines in your environment are spread throughout six different locations. I'm guessing these locations are on different sub-nets as well. Go to File -> Preferences -> Performance in PDQ Inventory. Change the the Service Manager TCP Connection to either Disabled, or Timeout with a five second value.

    Retry the scans after the change to the Service Manager TCP connection. Let us know how things go after the rescan.

    0
    Comment actions Permalink
  • Ryan Bill

    Thanks for the tip.

    I updated the setting to "Timeout - 5 seconds" and now when I try to run the scan all of the computers are stuck on "Queued".

    0
    Comment actions Permalink
  • SelfMan

    Can you ping the remote computers? Are you able to do the traceroute? Are you able to access the registry on the remote computers?

    RDP to the remote machine, start the taskmanager and check if the PDQInventory collector process is invoked.

    For me this looks like a firewall issue where packets are not returnet but dopped.

    0
    Comment actions Permalink
  • Ryan Bill

    Can you ping the remote computers? - Yes.

    Are you able to do the traceroute? - Yes.

    Are you able to access the registry on the remote computers? - No. (Regedit times out and becomes unresponsive whenever I attempt to use the "File -> Connect Network Registry..." option. This is after I've chosen the computer to connect to and click "OK". The computer names are resolving properly.)

    RDP to the remote machine, start the taskmanager and check if the PDQInventory collector process is invoked. - No, it is not being invoked.

    Nothing (to my knowledge) has changed since Friday on our firewall configs.

    0
    Comment actions Permalink
  • SelfMan

    Ok, are you able to access the remote admin$ share? i.e. \\myremotepc\admin$ or \\192.168.100.102\admin$.

    Please check also if the reverse DNS works properly.

    The reason for not beeing able to access the registry is  that the remote registry service is not runnig and that the firewall prevents the connection.

    Windows 7 needs to allow the connections to the remote registry through the firewall.Check this link http://technet.microsoft.com/en-us/library/cc738900(v=ws.10).aspx

    For a quick test, disable the local firewall on the remote machine and check if the PDQ inventory process is invoked.

     

    0
    Comment actions Permalink
  • Ryan Bill

    This issue is resolved because I restarted my server.

    Thank you SelfMan for all of your suggestions and tips. What ultimately tipped me off that there was something wrong with my server was when I was unable to open ANY remote directory including my data shares on any of my domain controllers or remote computers. Explorer kept freezing up on me and I finally gave up and did a reboot.

    All is well now :).

    0
    Comment actions Permalink
  • SelfMan

    I am glad you could resolve the issue.

    My next tip: check the network adapter drivers and also bios change log. Might be a good idea to update them.

    Todays motto:A reboot does not hurt...(much)

    0
    Comment actions Permalink

Please sign in to leave a comment.