access denied errors with PDQ inventory - Ping works but UNC path doesn't

Only some computers have the following error:

Target computer name mismatch

I checked DNS and the records are correct and there are no duplicate / old records on any DNS server here. I can ping the affected PC by host name and it resolves correctly. I can VNC into the affected machines. I cannot UNC path to them. Windows returns the following error when using UNC path:

Windows cannot access - Error Code 0x80004005 Unspecified Error

However if I use the IP address instead of the host name then UNC path works. So I KNOW this is DNS related but all three DNS servers show the correct A records for these PCs. For whatever reason they are resolving to the wrong PCs even though when I ping them by host name they resolve correctly. The affected machines and my machine I am running PDQ on have all had nslookup ran on them and they all show that they are using the same DNS server, our second domain controller.

The Windows firewall is turned off. File and printer share is turned on. I cannot do remote management on the affected PCs. Access Denied. I am a domain admin. Most PCs in PDQ Inventory work fine. Only a handful have the access denied/name mismatch problem. When I click the More Info link and try a remote repair here is what happens:

Connect to IPC$ Share

Logon failure: Target account name is incorect

Access Admin$ Share

Logon failure: target account name is incorrect

Create Service:

Access Denied

Read Privileges:

Access Denied


If I directly sit at the affected PC and use the PDQ Analyze tool with the same credentials as always it shows that everything passes. What? When I run the analyze function from my computer, it fails.



Changing the computer's name allows access again. Changing it back to what it was denies access again. Even though the A records in DNS are correct those particular computer names can now never be used again as they are somehow tied to IP addresses that DNS isn't showing. What would be responsible for this? This physical location where the affected computers are at has recently been given it's own DNS and DHCP and Domain Controller. The DNS records on that DNS are correct however and not every PC over there has this issue. Most are fine. There has to be some issue with the DNS server or maybe something wrong with the DHCP but I'm not the one that set those up so I'm not sure. What would cause this?




Date Votes
  • The thing I know of for this situation is to check for duplicate IPs in DNS. I see you have checked some information in DNS but it can be more tricky sometimes. How I do this is sort by name then highlight the affected computers name-then while that is highlighted sort by data and scroll to the highlighted row, everytime this happens to me I have 2 sometimes 3 names on the same IP address in DNS. I run into this problem often but it is because DNS hangs on to old records while DHCP hands an IP out to a new connection that is apart of those old DNS records resulting in PrObLeMs. Also if you have more than just the 2 DNS servers mentioned make sure you are checking all of them in case there is replication error preventing you from seeing the problems(we hand out a few DNS servers through DHCP) -If you run a nslookup what server is answering that lookup on these computers.

    Like I said this is what solves this for me- Hope it helps!

  • There is one more possible place. Have you checked your hosts file? You might have entered some entries there and forget about them.

    Also did you ipconfig /flushdns on the system you deploy packages from?

  • Take a look at this new blog post on Happy, Healthy DNS: How to resolve DNS Errors.

    Check out the section on using the nbtstat command.


Please sign in to leave a comment.

Didn't find what you were looking for?

New post