Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Deployment not working as expected

I am deploying a .bat file with some commands to install HP RM8 and when I run the install from PDQ-deploy it doesn't work properly. 

If I run the exact same .bat from the same location by right clicking and running as admin it does work fine. 


Can anyone explain why when I deploy with PDQ it doesn't run 'as admin' ? 




Date Votes
  • Hi Jordan, when you say that you are running it from the same location do you mean running it from ADMIN$? When running manually are you running using the same credentials that PDQ is using? Are you able to copy the contents of the .bat to this thread? (please sanitize any specific references to your organization such as IPs, hostnames, etc.)

    Is there an exit code that is being reported by PDQ Deploy that will shed light on the error?

  • Hi Shawn , 


    Thanks for the quick reply. 


    When I say the same location there is a network share \\servername\\Installs\HP\32bit.bat that I am calling it from. 

    When running it from PDQ-deploy I am using the domain admin account , when running it directly from the bat I am using my domain account. 


    There is no error , the install completes successfully but when the software loads up the configuration doesn't apply. Which suggests to me there is a permission error when running the install because the configuration parameters are specified in the .bat. 

    .bat contents are as follows : 


    msiexec /i "\\SERVERNAME\Installs\HP\HPRM 8.3.0 Patch 1 Build 9088\32BitInstalls\HPE_RM_x86.msi" /qn /l*vx "C:\RM8Install32Log.txt" INSTALLDIR="C:\Program Files (x86)\Hewlett-Packard Enterprise\Records Manager\" ADDLOCAL=HPTRIM,Client PRIMARYURL="SERVERNAME:1137" AUTHMECH="0" DEFAULTDBNAME="RCOW_DEV" DEFAULTDB="WD" AUTOGG=”1” TRIM_DSK="1" TRIMREF="DSK" EXCEL_ON="1" PROJECT_ON="1" POWERPOINT_ON="1" WORD_ON="1" OUTLOOK_ON="1" STARTMENU_NAME="HPE Records Manager"





  • Thanks Jordan. It helps to have the script contents. I'm going to need to have some of the support guys review this. It may take a bit longer due to a national holiday tomorrow, but I'll message them and see if they can take a look.

  • Thanks Shawn , Appreciate it. 


  • The only issue I see is the INSTALLDIR part because you have a trailing \ which escapes the "

    INSTALLDIR="C:\Program Files (x86)\Hewlett-Packard Enterprise\Records Manager\"

    I'm not sure why it would cause different behavior though, that's the kind of thing I would expect to be consistent. Try creating an Install package instead.

  • Hi Colby , 

    I have created a install package with the same result , this is why I turned to the CMD approach. 


    I have manually copied the 32bit.bat to c:\ then run it from the command line with 'C:\32bit.bat' which installed it correctly and opened with the default DB as expected. 


    Running this exact same process from PDQ-deploy results in the install working but not loading my default DB. 

    There is certainly something wrong with the way PDQ deploy is executing the commands , I am going to check the logs between a PDQ-deployment and the manual process to see if there is any indication. 

  • Ok I figured it out. 


    To shed some light for your personal knowledge. 

    When deploying using the domain admin account the install ran fine but it made some profile specific changes to the registry and folder structure. 

    By running my deployment as the logged on user (luckily they have local admin rights) the registry entries worked correctly for the logged in user. 


    Appreciate all the support guys and sorry to bother you with a problem that was probably my fault.