Deployment hangs on end of install of Visual Studio 2015 on Windows 10

Comments

4 comments

  • Official comment
    Nate Blevins

    Hey Max,

    I used the following parameters to install Visual Studio 2015 Update 3. The only parameter i didn't use that you did was /ProductKey since i didn't have one to try. I've uninstalled and -reinstalled 3 times. Each time it installs successfully on Windows 10.

    You mentioned the install exe showing as 0% CPU. The only process i see that you may be talking about is the Windows Installer service, which is constantly calling other installs for prerequisites and shows at 0% CPU through a large portion of the install. The Windows Installer services doesn't stop after the package successfully installs, but this is normal.  The install also takes some time, the average install was 15 minutes on very fast machines on a fast network, a slower network could take much longer.

    Let me know if this helps at all and if you're still having the issue.



    Comment actions Permalink
  • Max Williams

    Posted this 16 days ago and ... crickets lol figures

    Well just in case anyone else runs into this issue then here is what we did to get it working. A coworker did the smart thing and just skipped the "install" step and just ran it as a "command" step. Not sure why I didn't try that myself as that install step seems to cause more trouble than it is worth but that did the trick. If we ran it as an "install" it would only work when running it as "logged on user".

    So to recap Visual Studio 15 on Win 10 install as "Command" not "Install" and this command worked for us:
    "\\ServerName\Repository\PathToFile\vs_professional.exe" /adminfile "\\ServerName\Repository\PathToFile\AdminDeployment.xml" /quiet /norestart /ProductKey PutKeyHere

    Also you may need to gen the AdminDeployment.xml file. Don't remember the command to do it but google will help ;) Just remember we had issue if we didn't have that file for deployment. 

    0
    Comment actions Permalink
  • Shane Corellian

    Hi Max,

    Interesting. Not sure why this would succeed from the Command step. The only difference (assuming the Run As settings are the same) is that the command step runs from a cmd.exe process where as the Install step uses a Windows API to execute.Thanks for the info. We will spin this up and see if we can duplicate the behavior.

    0
    Comment actions Permalink
  • Max Williams

    @ we are still having issues as we do get mixed results but I can only assume at this point we have some unique variable in our process that is causing us issues. What we witness is the install will start and appear to continue for some time and depending on the conditions it will eventually finish in 40 minuets or longing but mostly longer.

    I have seen install times take about 40 minuets to hours applying to the exact same box rolled back to the exact same snapshot or install state. What will happen is somewhere around three quarters into the install it will just stall and CPU activity in general comes to a halt across all processes and just idles for some time but then by luck of the draw in some cases will continue back up or stay in a permanent comatose state. This pause will take up the bulk of the install time giving it that wide range of time to install. 

    I wish I had more detailed notes to give on what worked and what didn't, I should have made the effort to document each attempt and may have saved sometime but didn't. I have since then passed the task of pushing the creation of this deployment onto one of our help desk staff to see if he will have better luck than me at it and come at it from a different angle. 

    But combing over the Visual Studio logs all I was able to see was it just stops in the middle of an install and either picks up where it left or does not with no related error. The only reliable way I could ever get it to install was running it as a signed in user. I was able to achieve getting this to work in an automated way in PDQ by running a script that would place registry settings in the system to auto logon at boot then reboot then run the Visual Studio install as logged in user then remove the registry setting and reboot again.  This worked but it is sloppy and will be a break glass in case of emergency option.

    If we ever find the cause of this issue I will post it here.

    0
    Comment actions Permalink

Please sign in to leave a comment.