Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Trouble deploying Lucion FileCenter

Brand new user, trying the free version of Deploy currently.

I have a piece of software, called Lucion FileCenter,

It is distributed as a single executable, that is packaged with something called INNO setup ( )

I will post screen shots displaying all settings and errors,

The EXE's flags, obtained by doing /?, shown here.

Here is the package settings:

Executing the \\UNC\FileCenter...exe /VERYSILENT /LOG from a run dialogue box on the PC works as expected.

When trying to Deploy, using Deploy Once, I am not sure exactly what is happening as the LOG file is never created and I don't even think it gets to that point.  The Status will be stuck in running and it will never complete.

I did notice in the task manager, it seems to be doing some kind of copying of a tmp file but it never progresses past this point.  I am forced to Abort.

As you can see I am deploying with domain administrator credentials.

I really don't know where to start diagnosing, this would be SUCH a time saver for me and I hope I can some ideas on how to resolve this.

Thanks so much!







Date Votes
  • Hi Mike,

    Try checking the box to Include the Entire Directory.  Chances are when you ran it locally there were other files in the folder that were used by the installer and without checking that option, Deploy doesn't copy those files over with the install file.

  • You will likely see good results with Jason's suggestion. A lot of my exe deployments have extra files with them that need to be copied over as part of the process. 


    You may also want to drop the /LOG switch off your command and try running it. Typically with that switch you can say something like /LOG C:\temp\<installer>.log. Verify it's deploying successfully with the Include Entire Directory checkbox ticked and without /LOG, and then work on adding your /LOG switch to see what results you get. 

  • So, I kept the /LOG in, still seems to be same state of stuck :)

    Going to Abort and attempt without /LOG now.

  • So seems to be stuck in same state without the /LOG switch, but have some more evidence.

    At this point, job has run for 7 minutes...

    On the target machine, I did notice a few wierd things that seem to correlate with the start of deployment,

  • Just a bit more info, I did restart the target machine, tried again, same Application log entries.

  • Is this a free software or one that requires a license? If I can get it for free/trial I want to spin it up in my testing lab and see what I can come up with. I want you to use Deploy and Inventory. So let's get this successful so you can see the value in the software!

  • Diregard the last post. I saw you linked to it in your first post. Haha. I'm working on it now.

  • Good news, finally got that green check mark!

    The event log gave me the hint I needed, with the restart required.  This deployment is in fact a update more than a fresh install.  The program using a monitoring agent that is always running (FileAgent.exe).  I taskkill'd it and redeployed, and success!

    Now I would love a pro to tell me how to run a pre-job command to kill about two processes before starting the install?


  • In your package in PDQ Deploy you would create a Command Step, which will execute commands on the target computer. 

    New Step > Command Step : in the Command box put taskkill <arguments>


    Alternatively, and the method I prefer to use is the Powershell Step, which uses powershell to accomplish the same thing, but is a much nicer language and more powerful.


    I'd do something like this in powershell:


    Try {


    Stop-Process <details here>




    Exit 12345 (custom error code)



    This will give you an output.log on failures with the errors from powershell which is super nice for troubleshooting.

  • UPDATE:  So I did some research a found a few great examples of deployment batch files included in a compilation of free updated deployment packs and tools by a gentleman named vocatus that hangs in /r/sysadmin on Reddit.

    Using his examples I created a very simple batch file,

    %SystemRoot%\System32\taskkill.exe /f /im filecenter.exe
    %SystemRoot%\System32\taskkill.exe /f /im fileagent.exe
    \\myserver.domain.local\Installer\FileCenterSetup9-5-0-38.exe /VERYSILENT /LOG

    I place this in the DIR with my installer,

    Created a new Package,

    Worked first time!

    Thanks for all the help!

  • I am trying to install FileCenter as well but with an initial install instead of an update. The update seems to be hanging indefinitely.

    Any ideas what else I could try?