Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Solidworks: CLI install, works when run manually, but 1603 error from PDQd


I have a Solidworks Admin Image, which I am deploying to machines are two sites. On the 1st site, my PDQ package simply has step to run 

startswinstall.exe /install /now 

However, at my 2nd site, this never works and troubleshooting the installation errors with my VAR have not provided a solution. Even running the same command logged in locally on the machines generates an error which the VAR cannot resolve. So, a work around I'm comfortable with is avoiding the admin image and just installing the MSI's sequentially. My PDQ package for this 2nd site looks like this...

All the pre-reqs install fine. The problem starts with step 15, installing the first Solidworks MSI. My command is (I have sanitised for privacy)

msiexec.exe /i "SolidWorks.Msi" ALLUSERS=1 /qn /norestart /log output.log INSTALLDIR="C:\Program Files\SOLIDWORKS 2022" SOLIDWORKSSERIALNUMBER="XXXX" SERVERLIST=25734@Solidworks ENABLEPERFORMANCE=0 OFFICEOPTION=3 TOOLBOXFOLDER="\\\files\CAD\SW Toolbox\SW2022_Data" ADDLOCAL=CircuitWorks,CoreSolidWorksTaskScheduler,ExampleFiles,FeatureWorks,HelpFiles,Manuals,Motion,PhotoView,RealViewGraphicsdisplay,ScanTo3D,Simulation,SolidWorks,SolidWorksCosting,SolidWorksDesignChecker,SolidWorksRoutedsystems,SolidWorksToolbox,SolidWorksUtilities,TolAnalyst

This errors with 1603. When searching the log files for this error code I see the following lines

and finally 

The errors suggest a file is in use, which investigation suggests could be the Windows Search indexer. So, I added a step before this MSI which stops the Windows Search service, but still the same 1603 is logged.

What I'm confused about is if I manually run the same command whilst logged onto the target computer as the same PDQ deploy account, this completes successfully with a "0" code. 

I appreciate this might be specific to Solidworks, but has anyone had success running these commands via PDQ? Thanks.



1 comment
Date Votes
  • I haven't deployed Solidworks, but have a couple of thoughts. From the error, it looks like swdocumentmgr.dll is being used by SearchFilterHost. You mentioned stopping the process/service. You could also try adding a reboot step to see if it helps free things up.

    Have you tried changing the Run As mode? If you haven't yet, give "Deploy User(Interactive)" a try. Although the error that you are seeing doesn't sound related.