Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Solidworks PDQ package

Sorry, not a question, but a suggestion for those who are stuck with remotely installing SolidWorks with PDQ deploy, SCCM or other deployment software.

Guys, you are looking at the wrong documentation if you are trying to follow up their AD installation guide with installing prerequisites, you will always end up with error 1722 - sldShellExtServer.exe /REGSERVER no matter what you do.

The best solution I found is to use CMD step in PDQ deploy and startswinstall.exe with switches instead. I've lost all day yesterday trying to figure out what the hell's wrong with their documentation and stumbled accross different documentation from 2014 on this by accident.

Simply use SW setup to download and configure administrative package, don't bother with MST transforms, focus on SW administrative image option editor only because you'll be using their own .exe installer with switches for your install/uninstall needs.

CMD step:
"$(Repository)\SolidWorks\SOLIDWORKS 2016 SP4.0\startswinstall.exe" /install /showui /now

Switches are described here:-

Hope this reaches anyone else out there struggling to install Solidworks, it's ridiculous how such large expensive product does not properly support conventional install methods we're all used to.



Date Votes
  • Thanks for this - couldn't make heads or tails of their documentation. This worked perfectly.


  • Thanks. Very helpful.

     Although this does get Solidworks installed on the target computer, the PDQ task fails with "command script returned no error code". Is there a success code other than "0"?

  • Hi Michael,

    I have the following success codes on my Package: "0,1641,3010,2359302"

    Seems to work fine for me


  • Michael, it’s not the exe that returns exit code in this case, but cmd step that you wrap it in. It’s a popular way to deal with installers that returns nothing upon success.

  • Odd. When I add the codes that Jake suggested, it works on my Solidworks 2017 SP5 administrative image deployment, but not on Solidworks 2016 SP5 administrative image.

    This is despite the 2016 deployment finishing successfully on the actual target. The PDQ deployment times-out after 1 hour.

    The command in both deployments is identical, except for the exe it points to, eg...

    \\CAD\Solidworks\Installs\SW2016SP5\startswinstall.exe" /install /showui /now

    It's not a big deal. I would rather the deployment actually work, but report a failure, than not deploy at all.


  • Hi Michael,

    Are you deploying an Admin Image? I did have issues initially trying to find out if the product successfully installed or not. I had to dip into the logs in %temp% (under the account you installed it from in Deploy). Just doing a test deployment now to see if I can find the logs in question.



  • Hi Jake,

    Yes, I'm deploying from an admin image for both 2016 and 2017.

    I usually check the logs within the subfolder of wherever the admin image is installed, for example


    Alternatively, if I run the sldAdminOptionEditor.exe, and check the installation progress in there, it will simply read the info from the log file path above.


  • I am testing this on Solidworks 2019 SP3

    17 GB file copy though, I wonder if theres a better method

  • Kevin Still


    Did You manage to install SolidWorks SP3 or SP5 using PDQ?

    Can You describe how did You do it?


    I had a package for SW2018 SP1, SP2, SP5 and all was fine, but when I want to use with SW2019 I am getting timeout.


  • Hi,

    I did have issues with my first SW2019 admin image not deploying, despite not doing anything different to when I created packages for 2018 and previous versions.  This issue was that it DID install, but PDQ reported a failure.

    However, there was a discusson on the Solidworks forums about the unreliablity of admin images and someone suggested creating a fresh new image each time, which is not how I had been doing it. During the setup of a new admin image I was used to selecting the option to create the new image based off a previous image (and it would ask for the path to the previous image). The advice on the SW forums was not to do it this way, but select the option to create a fresh new image. This is more work as you have to import all the settings etc, but it allowed me to install SW 2019 and PDQ reported success, so I'll be using this approach for all future admin images.

    My current PDQ package is a SW 2019 SP4 image (created from scratch). The PDQ Deploy task is two steps:

    Step 1: Reboot (Solidworks installation won't progress if the computer has a pending reboot due to Windows updates)
    Step 2: Command: $(Repository)\SW2019SP4\startswinstall.exe /install /now

    Hope this helps.


  • Michael Yorke

    HI Thank You for your tip.

    I always used "fresh" image but i didn't have "reboot" step ad the beginning.

    In my 2018 package I have first step to remove 2015 reboot and install 2018 so maybe it was the reason.


    I will try and I will let You know.

  • "In my 2018 package I have first step to remove 2015" - interesting...! 

    How exactly are you getting 2015 removed? 

  • Anyone tried 2020 yet? I can get it installed but PDQ isn't detecting it actually being finished and eventually times out. I'm using command line install with \\unc\path\startswinstall.exe" /install /showui /now with success codes 0,1641,3010,2359302

  • Hi Ryan

    I haven't tried 2020 yet, but I get exactly what you describe with 2019. The deploymet just times out, but it does work. The install logs confirm it.

    I'll probably get around to looking at this in April, but from your experiences I'll probably hit the same issues.