Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.



Would love to see the OpenVPN client as a package, so we can keep the client version as updated as the server versions.






Date Votes
  • Official comment

    I'll look into this one, i see people are having issues silently installing it because of the certificate prompt. I think i can bypass by extracting the cert and installing it before the install. That will also give some time to see if anyone else is interested.

  • I would like to see this capability too! Or just the instructions on how to add the TAP driver to the driver store.

  • Here are screenshots of the steps i used in a Deploy package, that way you can make your own package until we decide whether or not we'll add it. For the cert, make sure you extract it from the EXE (I used 7-zip) then add it as a file in Step 1.

    Step 1 

    certutil -addstore "TrustedPublisher" .\openvpn.cer


    Step 2

    net stop "Openvpn Service"


    Step 3

    %SYSTEMROOT%\System32\taskkill.exe /f /im openvpn.exe /im openvpnserv.exe

  • Hmm. I'm not seeing openvpn.cer in my exe?? 

  • Adam,


    I opened the tap-windows.exe inside of the $TEMP folder. Inside that EXE is a driver folder. Inside the driver folder are 2 .cat files. I opened the first one. Selected View Signature, View Certificate, selected the Details tab, selected Copy to File, then used the default format and exported the cert.

  • Awesome! Thanks Nate!!

  • With all our staff now working remote multiple IP addresses are being forwarded to our DNS server when they are running OpenVPN. The IP address of their hardwired or WiFi network at their homes and the IP address of the OpenVPN virtual adapter. Most laptops are showing both addresses per host in our domains DNS server. PDQ picks up the IP address of the physical network of some systems, (the local IP on their home LAN) while others show up with the OpenVPN IP. PDQ works great when it locks onto the OpenVPN IP but fails when it pulls the local network IP as the systems IP. 

    I've tried tried using network discovery with PDQ inventory and entering the IP of the OpenVPN adapter but the scans don't seem to finish or update the system in PDQ deploy to the IP of the OpenVPN network. 

    Anyone else experience this and figure out a way to scan these systems and correct the IP being used by PDQ Inventory?