Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

PDQ11 simple command line to Windows 7 VM

Hi. First time posting here.

I am running Vmware Worstation with 2 VMs. First is Win2012R2 with PDQ deploy 11 installed. Second is Win7 Pro.


I am trying to run a simple command line such as GPUPDATE, but I keep getting Condition was not met. No steps were taken.


Both machine network are NAT with the same IP range and same subnet.

Any idea? I never use PDQ deploy before.



Date Votes
  • Save this as gpupdate.xml on your Deploy server.  Then in PDQ Deploy go to File > Import or hit Ctrl+I from within Deploy to import the xml document, which will create the package for you.


    <?xml version="1.0" encoding="utf-8"?>
    <AdminArsenal.Export Code="PDQDeploy" Name="PDQ Deploy" Version="" MinimumVersion="3.1">
    <PackageDefinition name="Definition">
    <InventoryScanProfileId value="null" />
    <RunAs value="null" />
    <ScanAfterDeployment value="null" />
    <Steps type="list">
    <Command>echo n | gpupdate /force</Command>
    <Conditions type="list">
    <IsEnabled value="true" />
    <Title>Run GPUpdate</Title>
    <Timeout value="60" />
    <UseCustomTimeout value="false" />
    <Description>Simple package to execute gpupdate /force on client machine, and bypass logoff prompt for user side settings.</Description>
    <FolderId value="3" />
    <Path>Powershell Scripts\GPUpdate</Path>
    <PackageDisplaySettings name="DisplaySettings">
    <SortOrder value="42" />
  • It still failed. I'm thinking there is something else causing the problem. Why would it says condition not met??

  • Can you post some screen shots? Of the package and of the failed deployment?

  • 0
  • I am able to run install just fine (with deploy user credential), but when I try to run CMD with logged on user... it keeps saying Conditions not met: No steps were able to run.


    Any idea?



  • Are you deploying to a machine that actually has a user logged into it? 


    Also, why the trailing S in your command definition? Typo?

  • That is a typo.


    Yes... I am trying to run command as logged on user. PDQ inventory does not has the option for logged user... so I looked into PDQ deploy (which I rarely touch).


    If this does works.. I will be able to run command that normally cannot run through system cred or admin cred. For example... I can run echo %logon server%... or check network drives/printers.. etc.

  • I run the command through deploy with an echo command so it does not reboot like this:

    echo n | gpupdate /force

    The only other difference is that I Run As: Deploy User

    I have no issues running gpupdate this way, hope this helps!

  • So after weeks of trying to figure out what went wrong... I found an installer for version 9.2. To my surprise... logged on CMD deploy works like charm. I guess version 10+ broke something in the conditioning... Can someone from Admin Arsenal looks into it?