Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Pushing Windows 10 1803 Update

Hello Everyone, I am running into an issue deploying the Windows 10 Spring Update 1803 with PDQ Deploy.  I had great success with pushing the 1709 version in fall, but the information here: does not seem to work the same for the 1803 update.  More specifically I am running into a timeout issue where the deployment hits 4 hours and then times out (what I set to increase the default setting)


I am not sure if the command line switches changed with this new version or what, but I am stuck on it as it won't push out.  Any ideas?




Date Votes
  • I posted the text below in the forum you listed but I'll post it here as well.  Christian's script works well for me.

    I just wanted to mention that I've been able to upgrade a few PCs from Windows 10 v1703 x64 to v1803 with Christian's script and I haven't had any issues.  Depending on hardware, I've had this upgrade complete in 30-120mins.  What I did was download the Microsoft Media Creation Tool, create an ISO for 64-bit only, extract the ISO to a directory in my repository, and then create a new package with the only step being a command step with his recommendation.  Thanks for the script!  It's working great!

    Command Step:  \\Server_Path_To_Extracted_ISO\setup.exe /Auto Upgrade /MigrateDrivers All /ShowOOBE none /Compat IgnoreWarning /Telemetry Disable

    Media Creation Tool:

  • So I did use that Media Creation Tool just as you described, and ran the following:


    \\PATHTOSHARE\setup.exe /quiet /forcerestart /auto upgrade /migratedrivers all /ShowOOBE none /Compat IgnoreWarning /Telemetry Disable /copylogs C:\Update_Logs\1803


    This worked in the past on previous deployments for the 1709 build, but every pc I have tried it on here ends up timing out.  When I look at the PC it has the Windows~BT folder like it should but the upgrade does not apply to the PC and it is left with a bunch of files copied on it, but no upgrade completed.

    Here is the Output Log:



    Any thoughts on why this might be?

  • Hi Mitchell,

    i'm sorry but it looks like your problem is a special problem based on your enviroment and hardware.

    I upgraded my Laptop from 1709 to 1803 without a problem using the command step.


  • Thanks for taking the time to look at this.  After more work and attempting to manually install 1803 on it, I am finding out that Dell appears to have an issue with some of their newer Optiplex systems where they don't support Windows 10 1803 without some special driver updates.  Apparently it has something to do with Secure Boot as well as the Chipset Drivers.  I am contacting Dell for support since these systems are only 1 year old and they are erroring out with the update. 


    So ultimately, this script likely works based on the comments above as well as my past experience when upgrading to 1709, but I won't be able to try it again for 1803 until I find out from Dell why it is not working with their setup.

  • I ran into a timeout isse as well in deploying 1803 that i got from MS licensing portal.  It prompts for the version of the OS you want to install (Education, Enterprise, Pro, Etc...)  From what i found there should be a couple of ways to handle it. 

    There is a /imageindex option as well as /pkey once i added the product key it worked great!

    The /imageindex is suggested in the comments on this page:


    I hope that helps!


  • You can also modify the wim file to only reference one imageindex. Make sure you remove the ImageIndex one at a time, the index number will decrease as you remove them. 

    Gather Info first 

    PS > Get-WindowsImage -ImagePath "\\<PATH TO  INSATLL.WIM>\sources\install.wim"

    ImageIndex : 1
    ImageName : Windows 10 Enterprise
    ImageDescription : Windows 10 Enterprise
    ImageSize : 15,649,800,180 bytes

    ImageIndex : 2
    ImageName : Windows 10 Pro
    ImageDescription : Windows 10 Pro
    ImageSize : 15,649,606,088 bytes

    ImageIndex : 3
    ImageName : Windows 10 Pro N
    ImageDescription : Windows 10 Pro N
    ImageSize : 14,571,662,920 bytes

    ImageIndex : 4
    ImageName : Windows 10 Pro Education
    ImageDescription : Windows 10 Pro Education
    ImageSize : 15,649,654,448 bytes


    This command will remove the reference to 

    ImageIndex : 2
    ImageName : Windows 10 Pro

    PS> Remove-WindowsImage -ImagePath "\\<PATH TO  INSATLL.WIM>\sources\install.wim" -Index 2 -CheckIntegrity