PDQ Inventory Memory Issue

I upgraded to PDQ Inventory yesterday afternoon, and I came back to a server with maximum memory used this morning. The PDQ Inventory Service was using 80GB of memory on a server I have setup with 32GB; massive paging file use. I restarted the server this morning, and within an hour and a half it was back up to 20GB of memory usage. I tried removing the application and reinstalling it, along with reboots before and after, and already the service is again climbing in memory usage. It's been running for around 10 minutes now and it's already up to 3GB.

Anyone else having issues with the latest version of Inventory and memory usage?



Date Votes
  • Rolling back to the previous release of PDQ Inventory resolved this issue, as it's been online for an hour and the PDQ Inventory Service is using less than 150MB of memory.

  • I'm having two different issues, but even with the database updates rolling back did not cause problems with your install? If I could get it back up, I might be able to fix the other issue which is a timeout for localhost:7337. I've created rules to make sure PDQ Inventory and port 7337 are not blocked by the firewall.





  • I'm getting the time out error after updating as well (I'll upgrade again to see if there were any memory problems). Rolling back to the previous version has fixed this both times that I've tested updating. Created a ticket last Thursday, not sure what all changed on the backend to be causing this much trouble for us. 

  • When you install an older version the database gets rolled back to the older version as well. I was worried about the database also, but luckily it's designed to roll back with a downgrade. I tried re-installing and uninstalling and installing from scratch. Either way I have the issue with memory usage, and with time I timeout when trying to connect as well. Going back to the old version is the way to resolve the issue until they release a fix.

  • I have the same issue as well.  Massive memory usage causing client connections to the server as well as local connections to the console to time out.  I suppose I will roll back the version until this is straightened out.

  • Have you contacted Support@pdq.com with these issues?  I believe there are some newer customer builds that might help and if the error persists after those are applied, any information you provide will help us narrow down the problem.

  • Hi Jason,

    I contacted Support and resolved the issue with one of their later builds (16 Release 2 Build 5 to be exact.)  Thanks for the follow up. 



Please sign in to leave a comment.

Didn't find what you were looking for?

New post