Important Notice: On February 29th, this community will be put into read-only mode. All existing posts will remain but customers will be unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Answered

NOT deploying a software package

Question: Is there a way to have PDQ Deploy check to see the existence of a specific application and version before applying the remaining components of a package to a system (or group of systems)?

Background: I have a package that uninstalls older versions of 7-Zip (pre 18.05) and then installs the most current version. However I would like to first check for the existence of 7-Zip 18.05; if it exists, end the process but it doesn't, run the remaining components. If the application and up-to-date version exist, then it shouldn't need to worry about the rest of the process.

I'm sure this has been answered already, but I wasn't able to find it. Thank you for any assistance provided.

David

0

Comments

7 comments
Date Votes
  • If you have PDQ Enterprise or Pro, you have a 7-Zip (old) Collections You can set up the conditions *is a Member" to the 7-Zip (old) Collection under the deploy conditions (see screenshot)

    enter image description here

    If you don't have Pro or Enterprise....run a Report -> Applications to find all old 7-Zip versions and use them as targets for your Deployment:

    enter image description here

    Or use the File Check under Conditions (keep in mind, x64 and x86 are different path, you have to set this up for both steps):

    enter image description here

    ~Chris

    0
  • Although we are running the Enterprise version, it's version 14 so we don't have the "Conditions" tab. :-\

    Guess I'll need to try the non-Pro/Enterprise process.

    0
  • enter image description here

    0
  • If i understand right, you have Enterprise (Deploy and Inventory) but the subscrition runs out and now you don't have a up to date Collection Library?

    You can still create a Custom Collection for the old Version:

    enter image description here

    And use them as target for Deploy in your schedule:

    enter image description here

    ~Chris

    0
  • Correct that we are running the Enterprise version, but not having any issues with the subscriptions.

    I'll try your suggestion on the custom collection. It looks like it will work for what I need.

    Thank you...

    0
  • If you have a current subscrition, you don't need a "custom collection" because there is a up to date 7-zip (old), (latest) and (not installed) inside the collection library of inventory.

    If not you should update to version 16, it could be that version 14 no longe receive the collection library updates

    0
  • I just upgraded to Deploy 16. We'll see how this goes.

    I'm still learning how best to use PDQ. The system was handed to me with a 5-10 minute overview... the rest was on my own.

    0

Please sign in to leave a comment.

Didn't find what you were looking for?

New post