Comments

7 comments

  • Wei

    Have you tried to kills the Slack process before running the installation process ?

    0
    Comment actions Permalink
  • Charles Zink

    I'm testing deployment on a fresh Windows 10 Enterprise image without Slack installed.

    0
    Comment actions Permalink
  • Wei

    Try download SlackSetup.exe and run "SlackSetup.exe -s"

    0
    Comment actions Permalink
  • Wei

    I just checked my own Slack package (v 3.2.0), currently it's done via choco (just run choco install slack -y as a PowerShell step).

    You need to have Choco package manager installed first, to install choco package manager just deploy the following script

    Set-ExecutionPolicy Bypass -Scope Process -Force; Invoke-Expression ((New-Object System.Net.WebClient).DownloadString('https://chocolatey.org/install.ps1')) 
    

    https://chocolatey.org/

    0
    Comment actions Permalink
  • Greg Mills

    I know this is an old thread, but I'm trying to install Slack using the per-user installer. It reports as having run successfully but hasn't. How do you diagnose a false positive?

    0
    Comment actions Permalink
  • Michael Yorke

    Hi,

    I'm just throwing my experience out there. When we started using Slack, we left it to users to install themselves (which they could do without admin rights). Their user installation ended up in %localappdata%\slack

    After a while we decided to standardise this, so wanted to remove the per-user installation and replace with the per-machine installation. Removing the per-user installation was important, as when having both installed on the same computer, the user would find two shortcuts on the start menu, both potentially different versions of Slack. The MSI's for both can be found at https://get.slack.help/hc/en-gb/articles/212475728-Deploy-Slack-via-Microsoft-Installer

    PDQ has a pre-built package for Slack, so I started with that and added my own pre-step to remove the per-user installation

    Command: "%LocalAppData%\slack\Update.exe" --uninstall -s
    Options: run as 'logged on user'
    

    Then my own post-script

    Command: "C:\Program Files\Slack\Slack.exe"
    Options: run as 'logged on user'
    

    Because the pre-built PDQ package kills the running slack.exe this post-script was meant to start it up again after the installation. However, despite this task working on Windows 7 (ie it does indeed start Slack) the task doesn't get notified so just waits and eventually times out. Seems to be working fine on Win10 though.

    0
    Comment actions Permalink
  • Roger Castillo

    Hi,

    Just sharing my experience on this. So basically I just used the downloadable MSI package of slack from where everyone else is downloading and instead of using the default installation, I use the custom command line option to add in an extra parameter. I use this for the custom installation.

    msiexec.exe /i "slack-standalone-4.6.0.0.msi" ALLUSERS=1 /qn /norestart /log output.log

    This will install slack on the machine and will be available to all profiles even for newly signed in profiles.

    Hope this helps. 

     

    Cheers!

    0
    Comment actions Permalink

Please sign in to leave a comment.