Important Notice: On February 29th, this community will be put into read-only mode. All existing posts will remain but customers will be unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

Answered

deployment of batch file not working in PDQ

Hi all, I have a simple batch file to stop a service and uninstall the software that works fine when I run the batch file on the computers using "run as administrator" but when I use PDQ to deploy the batch file it states that it was successful but nothing happens on the remote computers. I have tried using both the network and local admin accounts with the same result.

The service gets stopped and then the uninstall step should take about 30 seconds but it takes about 4 and then states "successful" but is not.

0

Comments

9 comments
Date Votes
  • Hi James,

    have you tried to put the commands directly into a cmd deploy step instead pointing to your batch file?

    Step 1: sc stop yourservice Step 2: your software Uninstall

    Greetings

    Christian

    0
  • Hi Christian, thanks for the reply. running direct commands gave me the same result.

    0
  • I guess I could create a shortcut for the batch file and go to the advanced options and "run as administrator". How do I go about copying the shortcut and batch file to the workstations and then running the shortcut in PDQ?

    0
  • Sure you can copy the batch file to C:, start the .bat with C:\yourbatch.bat and then delete the .bat from c:

    But its a little bit annoying, because i use plenty of cmd lines without any problem with PDQ. And admin rights are no problem with the right deploy user.

    Can you post the content of your batch file here?

    0
  • net stop sysaidagent

    "C:\Program Files\SysAid\UnInstallAgentUtilities.exe" "/c" "ClassicUninstall" "UserInterfaceMode"


    as I said, it is very simple. I don't understand why it won't work.

    Copying the bat and the shortcut, then running the shortcut as administrator didn't help.

    0
  • net stop? Sure this stops a service?

    Try this for a silent uninstall:

    sc stop sysaidagent

    "C:\Program Files\SysAid\UnInstallAgentUtilities.exe" "/c" "ClassicUninstall" "QuietMode"

    And maybe build in this:

    taskkill /F /IM SysAidSM.exe

    taskkill /F /IM SysAidWorker.exe

    sc delete SysAidAgent

    0
  • Thanks for the reply.

    I originally had it uninstall quietly, I was only forcing interface to see if it was working in my tests. Yes net stop was stopping the service for me but I can change it.

    I have added the taskkill's and it is now working perfectly!

    Thanks for your help Christian!

    0
  • Glad i could help, background exes are nasty if you try to update or uninstall a software.

    You're welcome

    0
  • Worked great

    0

Please sign in to leave a comment.

Didn't find what you were looking for?

New post