Oracle 12c Client

Trying to install Oracle cClient using an "Install" step from PDQ with the following command line and it fails

\servername\oracleclient\setup.exe -silent -ignoreSysPrereqs -ignorePrereq -responseFile \servername\oracleclient\response\client_install.rsp

It works if we launch the command locally on the workstation. We tried to copy the whole installation folder and put the command into a batch file. The batch runs fine locally on a workstation. But if you call the batch file from PDQ, it fails. We tried to run the command or call the batch from a Powershell step within PDQ. No luck.

Not matter which method we try. We are getting the following error on the output log.

Exit code of OUI process 259=

We are running out of idea. Anyone has a similar experience with Oracle Client and have any suggestions.

Thanks in advance



Date Votes
  • Oracle_Client12cR2.bat

    REM Copy folder Oracle Client 11gR2 and manually install via setup

    xcopy "\fileshare\Deploy\Oracle Client 12cR2\winx64_12102_client" /s /e c:\winx64_12102_client /y /i

    xcopy "\fileshare\Deploy\Oracle Client 12cR2\ClientResponse\client.rsp" /s /e "c:\ClientResponse" /y /i "c:\winx64_12102_client\client\setup.exe" -silent -responseFile "c:\ClientResponse\client.rsp"

    Created a PDQ package with command line step

    CALL "Oracle_Client12cR2.bat"

  • Thank you for your suggestion.

    However, we still cannot get it to work. The batch file is created. We make sure the batch file copies all necessary files to C:. Double check to make sure they are copied into C:\winx64_12102_client\client and c:\clientresponse folder.

    When PDQ executes the following command, it throws an error.

    "c:\winx64_12102_client\client\setup.exe" -silent -responseFile "c:\ClientResponse\client.rsp"

    enter image description here

  • Hmmm....

    i was looking over my old deployments...especially the failures, and noticed I was also receiving the exit code 259.

    Appears I cheated and simply added 259 to the success codes.

    Sorry I don't use the Oracle software myself and I haven't installed it this year. Didn't receive any feedback at the time, so unsure if it was working or not.

  • Thank you.

    When we get the error code, nothing got installed. So we really can not cheat the system.

  • I have an "app" folder (1.4GB) residing on the computers once deployed.

  • I got it working when adding the -waitforcompletion switch. This may help

    "C:\temp\winx64_12102_client\client\setup.exe" -silent -nowait -noconsole -waitforcompletion -responseFile "C:\temp\winx64_12102_client\client\client.rsp"


Please sign in to leave a comment.

Didn't find what you were looking for?

New post