Important Notice: On February 29th, this community was put into read-only mode. All existing posts will remain but customers are unable to add new posts or comment on existing. Please feel to join our Community Discord for any questions and discussions.

7-Zip/Adobe Reader update problems

Hello everyone,

lately I'm having some problems with the deployments, so I'm here asking for help.

7-Zip I'm trying to update 7-Zip x64 from 18.05 to 18.06 using the package downloaded from the Deploy Library. 18.05 had also been installed using the Deploy package, so as an .exe installer, not msi.

First Problem On several machines, the error code 1 appears: enter image description here Please notice that the package doesn't try to uninstall 18.05 x64 (exe version), so I suppose it just tries to update the existing version.

Second problem At this point, I tried to uninstall the 18.05 version by using both the uninstall package downloaded from the Library ("Uninstall 7-Zip 1.7 (9.20+)" and the manual command, but the program is still there. The uninstall does actually nothing. If I uninstall 7-Zip 18.05 manually from the Control Panel, then the 18.06 deployment works.

Adobe Reader DC First Problem On some machines, the "Adobe Reader DC Patch 19.010.20069" package deployment appears "Successful", but the software version doesn't get actually updated. On other machines, the error code 1622 appears. I tried several times, nothing changes. Until the previous version (19.010.20064), the patching packages had always worked. Keep in mind that the first Adobe Reader DC installation was also performed with the PDQ Deploy package.

Second problem So, I tried to use the "Uninstall Adobe Reader 2.0" package, but almost all the times it just keeps running and running until the timeout, without achieving its purpose.

Third problem What I tried next was to uninstall Adobe by running the related MsiExec.exe command. It worked, but now the package deployment gives me the error code 1603 and I'm stuck, without the possibility to deploy Adobe Reader anymore, even after a system restart. I tried by manually installing Adobe with its exe and it works.

Any ideas? Thanks.